您的位置:首页 > 其它

hdu1686 Oulipo

2015-06-12 12:08 267 查看
Problem Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination,
l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that
counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All
the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.



Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).

One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.



Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.



Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
***ERDXIVYERDIAN




Sample Output

1
3
0
这题也是kmp的模板题,做的时候在用kmp函数的时候,当j>=len2时,不能直接跳出循环,而是令j=next[j].直到i>=len1才跳出。
#include<stdio.h>
#include<string.h>
char s2[10006],s1[1000006];
int next[10006],len1,len2;

void nextt()
{
    int i,j;
    i=0;j=-1;
    memset(next,-1,sizeof(next));
    while(i<len2){
        if(j==-1 || s2[i]==s2[j]){
            i++;j++;next[i]=j;
        }
        else j=next[j];
    }
}

int kmp()
{
    int i,j,num=0;
    i=0;j=0;
    while(i<len1 && j<len2){
        if(j==-1 || s1[i]==s2[j]){
            i++;j++;
        }
        else j=next[j];
        if(j>=len2){
            num++;j=next[j];
        }
    }
    return num;
}

int main()
{
    int n,m,i,j,T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%s%s",s2,s1);
        len1=strlen(s1);
        len2=strlen(s2);
        nextt();
        printf("%d\n",kmp());
    }
    return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: