您的位置:首页 > 大数据 > 人工智能

Fibonacci Again

2015-06-08 13:35 357 查看

Time Limit: 2000/1000 MS
(Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 43312 Accepted Submission(s): 20674



Problem Description

There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

Input

Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

Output

Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.

Sample Input

0
1
2
3
4
5


Sample Output

no
no
yes
no
no
no


#include<stdio.h>

main()

{

int a,b,i,j;

while(scanf("%d",&a)!=EOF)

{

if((a-2)%4==0)

printf("yes\n");

else printf("no\n");

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: