您的位置:首页 > 产品设计 > UI/UE

POJ 1679 THE UNIQUE MST 【次小生成树】

2015-06-05 23:47 519 查看
The Unique MST

Time Limit: 1000MS Memory Limit: 10000K

Total Submissions: 22098 Accepted: 7847

Description

Given a connected undirected graph, tell if its minimum spanning tree is unique.

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V’, E’), with the following properties:

1. V’ = V.

2. T is connected and acyclic.

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E’) of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E’.

Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.

Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string ‘Not Unique!’.

Sample Input

2

3 3

1 2 1

2 3 2

3 1 3

4 4

1 2 2

2 3 2

3 4 2

4 1 2

Sample Output

3

Not Unique!

Source

POJ Monthly–2004.06.27 srbga@POJ

代码:

[code]#include <stdio.h>  
#include <iostream>  
#include <string.h>  
#include <algorithm>  
#include <math.h>  
#include <stack>  
#include <queue>  
#include <set>  

using namespace std;  
#define INF 10000000  

/* 
 * 次小生成树 
 * 求最小生成树时,用数组Max[i][j]来表示MST中i到j最大边权 
 * 求完后,直接枚举所有不在MST中的边,替换掉最大边权的边,更新答案 
 * 点的编号从1开始 
 */  
const int MAXN=110;  
bool vis[MAXN];  
int lowc[MAXN];  
int pre[MAXN];//记录前驱节点  
int Max[MAXN][MAXN];//Max[i][j]表示在最小生成树中从i到j的路径中的最大边权  
bool used[MAXN][MAXN];//是否是最小生成树的边  

int Prim(int cost[][MAXN],int n)  
{  
    int ans=0;  
    memset(vis,false,sizeof(vis));  
    memset(Max,0,sizeof(Max));  
    memset(used,false,sizeof(used));  
    memset(lowc,0,sizeof(lowc));  

    for(int i=1;i<=n;i++)  
    {  
        lowc[i]=cost[1][i];  
        pre[i]=1;  
    }  
    lowc[1]=0;  
    vis[1]=true;  
    pre[1]=-1;   

    for(int i=1;i<n;i++)  
    {  
        int minc=INF;  
        int p=-1;  
        for(int j=1;j<=n;j++)  
            if(!vis[j] && minc > lowc[j])  
            {  
                minc = lowc[j];  
                p = j;  
            }  
        if(minc==INF)  
            return -1;  

        ans += minc;  
        vis[p]=true;  
        used[p][pre[p]]=used[pre[p]][p]=true;  

        for(int j=1;j<=n;j++)  
        {  
            if(vis[j])  
                Max[j][p]=Max[p][j]=max(Max[j][pre[p]],lowc[p]);  

            if(!vis[j]&&lowc[j]>cost[p][j])  
            {  
                lowc[j]=cost[p][j];  
                pre[j]=p;  
            }  
        }  
    }  
    return ans;  
}  
int ans;  
int smst(int cost[][MAXN],int n)//求次小生成树  
{  
    int Min=INF;  
    for(int i=1;i<=n;i++)  
        for(int j=i+1;j<=n;j++)  
            if(cost[i][j]!=INF && !used[i][j])  
            {  
                Min=min(Min,ans+cost[i][j]-Max[i][j]);  
            }  
    if(Min==INF)  
        return -1;//不存在  
    return Min;  
}  
int cost[MAXN][MAXN];  
int main()  
{  
    int T;  
    int n,m;  
    scanf("%d",&T);  
    while(T--)  
    {  
        scanf("%d%d",&n,&m);  
        int u,v,w;  
        for(int i=1;i<=n;i++)  
            for(int j=1;j<=n;j++)  
            {  
                if(i==j)  
                    cost[i][j]=0;  
                else  
                    cost[i][j]=INF;  
            }  
        while(m--)  
        {  
            scanf("%d%d%d",&u,&v,&w);  
            if (cost[u][v] > w)  
                cost[u][v]=cost[v][u]=w;  
        }  

        ans=Prim(cost,n);  
        if(ans==smst(cost,n))  
            printf("Not Unique!\n");//次小生成树和最小生成树一样大  
        else  
            printf("%d\n",ans);  
    }  
    return 0;  
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: