您的位置:首页 > 大数据 > 人工智能

UVa 514 - Rails

2015-06-02 20:23 253 查看
Rails
There is a famous railway station in PopPush City. Country there is incredibly hilly. The station was built in last century. Unfortunately, funds were extremely limited that time. It was possible to establish only a surface track. Moreover, it turned out
that the station could be only a dead-end one (see picture) and due to lack of available space it could have only one track.



The local tradition is that every train arriving from the direction A continues in the direction B with coaches reorganized in some way. Assume that the train arriving from the direction A has


coaches numbered in increasing order

. The chief for train reorganizations must know whether it is possible to marshal coaches
continuing in the direction B so that their order will be

. Help him and write a program that decides whether it is
possible to get the required order of coaches. You can assume that single coaches can be disconnected from the train before they enter the station and that they can move themselves until they are on the track in the direction B. You can also suppose that at
any time there can be located as many coaches as necessary in the station. But once a coach has entered the station it cannot return to the track in the direction A and also once it has left the station in the direction B it cannot return back to the station.

input

The input file consists of blocks of lines. Each block except the last describes one train and possibly more requirements for its reorganization. In the first line of the block there is the integerN described above. In each of the next lines of
the block there is a permutation of

The last line of the block contains just 0.

The last block consists of just one line containing 0.

output

The output file contains the lines corresponding to the lines with permutations in the input file. A line of the output file containsYes if it is possible to marshal the coaches in the order required on the corresponding line of the input file. Otherwise
it containsNo. In addition, there is one empty line after the lines corresponding to one block of the input file. There is no line in the output file corresponding to the last ``null'' block of the input file.

sample input

5
1 2 3 4 5
5 4 1 2 3
0
6
6 5 4 3 2 1
0
0


sample output

Yes
No

Yes


有n辆火车 按1到n的顺序进站 最后进站的车可以在任何时候出去 判断给定的出站序列是否可能。

#include<cstdio>
#include<stack>
using namespace std;
const int maxn=10010;
int n;
int main(){
while(scanf("%d",&n)==1&&n){
int qqq;
while(scanf("%d",&qqq)&&qqq){
int target[maxn];
target[1]=qqq;
for(int i=2;i<=n;i++){
scanf("%d",&target[i]);
}
stack<int>s;
int A=1,B=1;
bool OK=1;
while(B<=n){
if(A==target[B]){A++;B++;}
else if(!s.empty()&&s.top()==target[B]){s.pop();B++;}
else if(A<=n)s.push(A++);
else{OK=0;break;}
}
printf(OK?"Yes\n":"No\n");
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: