您的位置:首页 > 大数据 > 人工智能

POJ 3250 Bad Hair Day 简单DP 好题

2015-05-29 22:48 246 查看
DescriptionSome of Farmer John's N cows (1 ≤ N ≤ 80,000) are having a bad hair day! Since each cow is self-conscious about her messy hairstyle, FJ wants to count the number of other cows that can see the top of other cows' heads.Each cow i has a specified height hi (1 ≤ hi ≤ 1,000,000,000) and is standing in a line of cows all facing east (to the right in our diagrams). Therefore, cow i can see the tops of the heads of cows in front of her (namely cows i+1, i+2, and so on), for as long as these cows are strictly shorter than cow i.Consider this example:
=
=       =
=   -   =         Cows facing right -->
=   =   =
= - = = =
= = = = = =
1 2 3 4 5 6

Cow#1 can see the hairstyle of cows #2, 3, 4
Cow#2 can see no cow's hairstyle
Cow#3 can see the hairstyle of cow #4
Cow#4 can see no cow's hairstyle
Cow#5 can see the hairstyle of cow 6
Cow#6 can see no cows at all!Let ci denote the number of cows whose hairstyle is visible from cow i; please compute the sum of c1 through cN.For this example, the desired is answer 3 + 0 + 1 + 0 + 1 + 0 = 5.InputLine 1: The number of cows, N.
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i.
OutputLine 1: A single integer that is the sum of c1 through cN.
Sample Input
6
10
3
7
4
12
2

Sample Output
5

题意: 有n头牛从左到右排成一行,从左到右编号为1~n,并且牛的头是朝向右的,即每头牛只可以看到他们右边的牛。
现在给出n头牛的身高,设c[i]表示第i头牛可以看到多少头牛的头顶。
求所有c[i]的和。

简单DP

设dp[i]表示第i头牛在看的时候是被第dp[i]头牛挡住视线的,即i+1~dp[i]-1这个区间的牛都可以被第i头牛看到。
所以第i头牛看到的数目为:dp[i]-i-1

这道题也可以用栈来做。
#include<cstdio>
#include<cstring>
#include<algorithm>

const int maxn=80000+5;
const long long inf=0x3f3f3f3f;

#define LL long long

LL h[maxn];
LL dp[maxn];

int main()
{
int n;
while(~scanf("%d",&n))
{
for(int i=1;i<=n;i++)
{
scanf("%lld",&h[i]);
}
n++;
h[0]=h
=inf;

for(int i=n-1;i>0;i--)
{
int tmp=i+1;
dp[i]=i+1;
while(h[i]>h[tmp])
{
dp[i]=dp[tmp];
tmp=dp[tmp];
}
}
LL ans=0;
for(int i=1;i<n;i++)
{
ans+=(dp[i]-i-1);
}
printf("%lld\n",ans);
}
return 0;
}
188ms

                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: