您的位置:首页 > 其它

poj 3630 Phone List 【字典树】【判断一个字符串集里面 是否存在一个字符串是另一个字符串前缀】

2015-05-29 14:17 344 查看
Phone List
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 24363Accepted: 7444
Description

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let's say the phone catalogue listed these numbers:

Emergency 911
Alice 97 625 999
Bob 91 12 54 26

In this case, it's not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob's phone number. So this list would not be consistent.

Input

The first line of input gives a single integer, 1 ≤ t ≤ 40, the number of test cases. Each test case starts with
n, the number of phone numbers, on a separate line, 1 ≤ n ≤ 10000. Then follows
n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

Output

For each test case, output "YES" if the list is consistent, or "NO" otherwise.

Sample Input
2
3
911
97625999
91125426
5
113
12340
123440
12345
98346

Sample Output
NO
YES

第二道字典树:125ms

#include <cstdio>
#include <cstring>
#define MAX 100000+10
using namespace std;
int ch[MAX][10];
int word[MAX];
char str[10100][10];
int n, sz;
void init()
{
    sz = 1;
    memset(ch[0], 0, sizeof(ch[0]));
    memset(word, 0, sizeof(word));
}
int idx(char x)
{
    return x - '0';
}
void insert(char *s)
{
    int i, j, l = strlen(s);
    int u = 0;
    for(i = 0; i < l; i++)
    {
        int c = idx(s[i]);
        if(!ch[u][c])
        {
            memset(ch[sz], 0, sizeof(ch[sz]));
            ch[u][c] = sz;
            sz++;
        }
        u = ch[u][c];
        word[u]++;
    }
}
int find(char *s)
{
   int i, j, l = strlen(s);
   int u = 0;
   for(i = 0; i < l; i++)
   {
       int c = idx(s[i]);
       u = ch[u][c];
       if(word[u] == 1)//找到可确定前缀 
       return 1;
   } 
   return 0;//找不到可确定前缀 
}
int main()
{
    int t, i;
    int exist;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d", &n);
        init();
        for(i = 0; i < n; i++)
        {
            scanf("%s", str[i]);
            insert(str[i]);
        }
        exist = 1;
        for(i = 0; i < n; i++)
        {
            if(!find(str[i]))
            {
                exist = 0;
                break;
            }
        }
        if(exist)
        printf("YES\n");
        else
        printf("NO\n");
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: