您的位置:首页 > 其它

hdoj 1024 Max Sum Plus Plus 【动态规划经典题目】【m子段和】

2015-06-03 23:02 288 查看

Max Sum Plus Plus

[b]Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 19598 Accepted Submission(s): 6462

[/b]

Problem Description
Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S1, S2, S3, S4
... Sx, ... Sn (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ Sx ≤ 32767). We define a function sum(i,
j) = Si + ... + Sj (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i1, j1) + sum(i2,
j2) + sum(i3, j3) + ... + sum(im,
jm) maximal (ix ≤ iy ≤ jx or ix
≤ jy ≤ jx is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(ix, jx)(1
≤ x ≤ m) instead. ^_^

Input
Each test case will begin with two integers m and n, followed by n integers S1, S2, S3
... Sn.

Process to the end of file.

Output
Output the maximal summation described above in one line.

Sample Input
1 3 1 2 3
2 6 -1 4 -2 3 -2 3


Sample Output
6
8

Hint
Huge input, scanf and dynamic programming is recommended.





我们用dp[i][j]表示i个子段和的最大值且第i个子段包含a[j]项

则有状态方程:

dp[i][j] = max(dp[i][j-1]+a[j], max(dp[i-1][t]+a[j])) 这里i-1 <= t <= n

我们可以用一个rec二维数组记录max(dp[i-1][t]+a[j]) i-1 <= t <= n

这样就可以用rec[i][j]代表前j个元素的i个子段和的最大值。

但是这样空间复杂度很高,可以用01背包思想优化一下 把二维数组压缩成一维,就ok了。


#include <cstdio>
#include <cstring>
#include <algorithm>
#define INF 0x3f3f3f
#define MAX 1000000+10
using namespace std;
int a[MAX];
int rec[MAX], dp[MAX];
int main()
{
    int n, m;
    int i, j;
    int ans;
    while(scanf("%d%d", &m, &n) != EOF)
    {
        for(i = 1; i <= n; i++)
        {
            scanf("%d", &a[i]);
            dp[i] = rec[i] = 0;
        }
        dp[0] = rec[0] = 0;
        for(i = 1; i <= m; i++)//从第1个子段 到 第m个子段 
        {
            ans = -INF;
            for(j = i; j <= n; j++)
            {
                dp[j] = max(dp[j-1]+a[j], rec[j-1]+a[j]);//求得dp[i][j]当前最大值 
                rec[j-1] = ans;//rec[j-1]代表前j-1个元素的i个子段和最大值,注意不是rec[j]因为还不知道ans和dp[j]的关系;
                ans = max(ans, dp[j]);//更新字段最大和 
            }
        }
        printf("%d\n", ans);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: