您的位置:首页 > 大数据 > 人工智能

一些项目——Fibonacci Again

2015-05-28 17:09 260 查看


Problem Description

There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).


Input

Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).


Output

Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.


Sample Input

0
1
2
3
4
5



Sample Output

no
no
yes
no
no
no


代码

#include <iostream>
using namespace std;
int main()
{
    long n;
    while(cin>>n)
    {
        if(n>0&&(n-2)%4==0)
            cout<<"yes"<<endl;
        else
            cout<<"no"<<endl;
    }
    return 0;
}


计算一下前100个数列的值可以发现,从f(2)开始,每过4个数就能被3整除,所以只要看输入的值减去2是不是能被4整除就行。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: