您的位置:首页 > 其它

ACM-sum of all integer numbers

2015-05-27 12:01 441 查看
描述 Your task is to find the sum of all integer numbers lying between 1 and N inclusive.
输入There are multiple test cases.

The input consists of a single integer N that is not greater than 10000 by it's absolute value.输出Write a single integer number that is the sum of all integer numbers lying between 1 and N inclusive.样例输入
3

样例输出
6


代码:

01.
#include<iostream>

02.
using

namespace
std;

03.
#include <stdio.h>

04.
int

main()

05.
{

06.
int

n;

07.
int

t;

08.
while
(
scanf
(
"%d"
,&n)==1)

09.
{

10.
if
(n > 0)

11.
printf
(
"%d\n"
,(1+n)*n/2);

12.
else

if
(n ==0)

13.
printf
(
"%d\n"
,1);

14.
else

15.
{

16.
t = -n;

17.
printf
(
"%d\n"
,-(1+t)*t/2+1);

18.
}

19.
}

20.

21.
return

0;

22.
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: