您的位置:首页 > 其它

HDU 1175 连连看 (BFS带方向的判定)

2015-05-19 01:31 363 查看

连连看

Time Limit: 20000/10000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 23172 Accepted Submission(s): 5710


[align=left]Problem Description[/align]
“连连看”相信很多人都玩过。没玩过也没关系,下面我给大家介绍一下游戏规则:在一个棋盘中,放了很多的棋子。如果某两个相同的棋子,可以通过一条线连起来(这条线不能经过其它棋子),而且线的转折次数不超过两次,那么这两个棋子就可以在棋盘上消去。不好意思,由于我以前没有玩过连连看,咨询了同学的意见,连线不能从外面绕过去的,但事实上这是错的。现在已经酿成大祸,就只能将错就错了,连线不能从外围绕过。
玩家鼠标先后点击两块棋子,试图将他们消去,然后游戏的后台判断这两个方格能不能消去。现在你的任务就是写这个后台程序。

[align=left]Input[/align]
输入数据有多组。每组数据的第一行有两个正整数n,m(0<n<=1000,0<m<1000),分别表示棋盘的行数与列数。在接下来的n行中,每行有m个非负整数描述棋盘的方格分布。0表示这个位置没有棋子,正整数表示棋子的类型。接下来的一行是一个正整数q(0<q<50),表示下面有q次询问。在接下来的q行里,每行有四个正整数x1,y1,x2,y2,表示询问第x1行y1列的棋子与第x2行y2列的棋子能不能消去。n=0,m=0时,输入结束。
注意:询问之间无先后关系,都是针对当前状态的!

[align=left]Output[/align]
每一组输入数据对应一行输出。如果能消去则输出"YES",不能则输出"NO"。

[align=left]Sample Input[/align]

3 4
1 2 3 4
0 0 0 0
4 3 2 1
4
1 1 3 4
1 1 2 4
1 1 3 3
2 1 2 4
3 4
0 1 4 3
0 2 4 1
0 0 0 0
2
1 1 2 4
1 3 2 3
0 0

[align=left]Sample Output[/align]

YES
NO
NO
NO
NO
YES

解题思路:
  一个带方向的bfs题目,自从上次网络赛结束,发现我欠缺的就是解决这种题的能力,所以我得花更多的时间来进行这方面的练习。
代码:

# include<cstdio>
# include<iostream>
# include<cstring>
# include<queue>

using namespace std;

# define MAX 1234

struct node
{
int x,y;
int direction;
int turn;
};

int flag;
int x11,x22,y11,y22;
int book[MAX][MAX][4];
int grid[MAX][MAX];
int nxt[4][2] = {{0,1},{-1,0},{0,-1},{1,0} };

int n,m;
queue<node>Q;

int can_move ( int x,int y )
{
if ( x>=1&&x<=n&&y>=1&&y<=m )
return 1;
else
return 0;
}

void init()
{
while ( !Q.empty() )
{
Q.pop();
}
memset(book,0,sizeof(book));
}

void bfs ( node start )
{
init();
Q.push(start);
while ( !Q.empty() )
{
node now = Q.front();
Q.pop();
if ( now.turn > 2 )
continue;
if ( now.x==x22&&now.y==y22 )
{
flag = 1;
return;
}

for ( int i = 0;i < 4;i++ )
{
int tx = now.x+nxt[i][0], ty = now.y+nxt[i][1];
if ( can_move(tx,ty)==0||book[now.x][now.y][i]==1 )
continue;
node newnode;
newnode.x = tx; newnode.y = ty;
if ( (tx==x22&&ty==y22)||grid[tx][ty]==0 )
{
if ( now.direction == -1||now.direction==i )
{
newnode.direction = i;
newnode.turn = now.turn;
}
else
{
newnode.direction = i;
newnode.turn = now.turn+1;
}
book[now.x][now.y][i] = 1;
Q.push(newnode);
}
}
}
}

int main(void)
{
while ( scanf("%d%d",&n,&m)!=EOF )
{
if ( n==0&&m==0 )
break;
for ( int i = 1;i <= n;i++ )
{
for ( int j = 1;j <= m;j++ )
{
scanf("%d",&grid[i][j]);
}
}

int q;scanf("%d",&q);
while ( q-- )
{
flag = 0;
scanf("%d%d%d%d",&x11,&y11,&x22,&y22);
node start;
start.x = x11; start.y = y11; start.turn = 0;start.direction = -1;
if ( (grid[x11][y11]==grid[x22][y22])&&grid[x11][y11]!=0 )
bfs(start);
if ( flag )
printf("YES\n");
else
printf("NO\n");
}
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: