您的位置:首页 > 产品设计 > UI/UE

Problem A Number Sequence(KMP基础)

2015-05-29 01:27 459 查看
A - Number Sequence
Time Limit:5000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Submit Status Practice HDU 1711

Description

Given two sequences of numbers : a[1], a[2], ...... , a
, and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a
. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

Sample Input

2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1

Sample Output

6 -1

题目大意:
  给你一个长度为n和长度为m的串,然后让你求出这个长度为m的串第一次在长度为n的串中出现的下标是什么(当然是完全匹配后的),如果有
多个地方出现了这个长度为m的串,那我们就输出最小的下标编号。

解题思路:

  直接上kmp,先对模式串通过O(m)的时间复杂度,计算出next[],然后通过kmp找到找到第一次匹配成功的模式串在文本串中的位置,然后输出

t1-len2+1就OK了。

代码:

# include<cstdio>
# include<iostream>
# include<cstring>

using namespace std;

int a[1000004];
int b[10004];
int nxt[10004];
int n,m;

void get_next()
{
int len = m;
int t1 = 0, t2;
t2 = nxt[0] = -1;
while ( t1<len )
{
if ( t2==-1||b[t1]==b[t2] )
{
t1++;t2++;
nxt[t1] = t2;
}
else
t2 = nxt[t2];
}
}

int kmp ( int *a,int *b )
{
int len1 = n, len2 = m;
int t1 = 0,t2 = 0;
while ( t1<len1&&t2<len2 )
{
if ( t2==-1||a[t1]==b[t2] )
{
t1++;t2++;
}
else
t2 = nxt[t2];
}
if ( t2==len2 )
return t1-t2+1;
else
return -1;
}

int main(void)
{
int t;scanf("%d",&t);
while ( t-- )
{
scanf("%d%d",&n,&m);
for ( int i = 0;i < n;i++ )
scanf("%d",&a[i]);
for ( int j = 0;j < m;j++ )
scanf("%d",&b[j]);
get_next();
int ans = kmp(a,b);
printf("%d\n",ans);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: