您的位置:首页 > 其它

HDU 1548 A strange lift

2015-05-15 20:08 239 查看

A strange lift

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 14488 Accepted Submission(s): 5497



Problem Description
There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will
go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there
is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2
th floor,as you know ,the -2 th floor isn't exist.

Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"?



Input
The input consists of several test cases.,Each test case contains two lines.

The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.

A single 0 indicate the end of the input.


Output
For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".


Sample Input
5 1 5
3 3 1 2 5
0




Sample Output
3


#include <iostream>
#include <stdio.h>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#define N 2020
using namespace std;

int A,B,n;
int s
;
int mp
;

struct Node
{
    int a,b;
}f,t,g;

int main()
{
    while(~scanf("%d",&n))
    {
        if(n==0) break;

        scanf("%d %d",&A,&B);

        for(int i=1;i<=n;i++)
        {
            scanf("%d",&s[i]);
            mp[i]=0;
        }

        queue<Node>q;
        mp[A]=1;
        f.a=A;
        f.b=0;

        q.push(f);

        int ans=-1;

        while(!q.empty())
        {
            t=q.front();
            q.pop();

            if(t.a==B)
            {
                ans=t.b;
                break;
            }

            f.a=t.a+s[t.a];
            g.a=t.a-s[t.a];

            if(f.a>0 && f.a<=n && mp[f.a]==0)
            {
                mp[f.a]=1;
                f.b=t.b+1;
                q.push(f);

            }

            if(g.a>0 && g.a<=n && mp[g.a]==0)
            {
                mp[g.a]=1;
                g.b=t.b+1;
                q.push(g);
            }

        }

        if(ans==-1)
        cout<<-1<<endl;
        else
        cout<<ans<<endl;

    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: