您的位置:首页 > 其它

POJ 1195 Mobile phones(二维树状数组)

2015-04-22 20:05 113 查看
Mobile phones

Time Limit: 5000MSMemory Limit: 65536K
Total Submissions: 15968Accepted: 7373
Description

Suppose that the fourth generation mobile phone base stations in the Tampere area operate as follows. The area is divided into squares. The squares form an S * S matrix with the rows and columns numbered from 0 to S-1. Each square contains a base station. The
number of active mobile phones inside a square can change because a phone is moved from a square to another or a phone is switched on or off. At times, each base station reports the change in the number of active phones to the main base station along with
the row and the column of the matrix.

Write a program, which receives these reports and answers queries about the current total number of active mobile phones in any rectangle-shaped area.

Input

The input is read from standard input as integers and the answers to the queries are written to standard output as integers. The input is encoded as follows. Each input comes on a separate line, and consists of one instruction integer and a number of parameter
integers according to the following table.



The values will always be in range, so there is no need to check them. In particular, if A is negative, it can be assumed that it will not reduce the square value below zero. The indexing starts at 0, e.g. for a table of size 4 * 4, we have 0 <= X <= 3 and
0 <= Y <= 3.

Table size: 1 * 1 <= S * S <= 1024 * 1024

Cell value V at any time: 0 <= V <= 32767

Update amount: -32768 <= A <= 32767

No of instructions in input: 3 <= U <= 60002

Maximum number of phones in the whole table: M= 2^30

Output

Your program should not answer anything to lines with an instruction other than 2. If the instruction is 2, then your program is expected to answer the query by writing the answer as a single line containing a single integer to standard output.
Sample Input
0 4
1 1 2 3
2 0 0 2 2 
1 1 1 2
1 1 2 -1
2 1 1 2 3 
3

Sample Output
3
4

Source

IOI 2001

题意:第一行输入两个数据id,n,分别代表编号和矩阵的大小,后面的数据每一行第一个数据代表编号,1代表会输入3个数想,有,z代表将矩阵中位置行x,列为y的元素加z(初始化矩阵中所有的元素都为0),2代表会输入4个数xx,yy,x,y。代表输出左上角坐标为x,y,右下角坐标为xx,yy的矩阵中所有元素的和

#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>

using namespace std;

const int maxn = 1025;

int n,id;
int c[maxn][maxn];

int lowbit(int x)
{
    return x&(-x);
}

void updata(int i,int j,int k)
{
    while(i<=n)
    {
        int pj = j;
        while(pj<=n)
        {
            c[i][pj] += k;
            pj += lowbit(pj);
        }
        i += lowbit(i);
    }
}

int getsum(int i,int j)
{
    int sum = 0;
    while(i>0)
    {
        int pj = j;
        while(pj>0)
        {
            sum += c[i][pj];
            pj -= lowbit(pj);
        }
        i -= lowbit(i);
    }
    return sum;
}

int main()
{
    scanf("%d%d",&id,&n);
    int x,y,z,xx,yy;
    while(scanf("%d",&id)!=EOF)
    {
        if(id == 3)
        {
            break;
        }
        if(id == 1)
        {
            scanf("%d%d%d",&x,&y,&z);
            x++;
            y++;
            updata(x,y,z);
        }
        else if(id == 2)
        {
            scanf("%d%d%d%d",&x,&y,&xx,&yy);
            x++;
            y++;
            xx++;
            yy++;
            printf("%d\n",getsum(xx,yy)-getsum(x-1,yy) - getsum(xx,y-1) + getsum(x-1,y-1));
        }
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: