您的位置:首页 > 其它

zoj 3329 One Person Game 概率dp

2015-04-18 10:16 429 查看
One Person Game

Time Limit: 1 Second Memory Limit: 32768 KB Special Judge

There is a very simple and interesting one-person game. You have 3 dice, namely Die1, Die2 and Die3. Die1 has K1 faces. Die2 has K2 faces. Die3 has K3 faces.
All the dice are fair dice, so the probability of rolling each value, 1 to K1, K2, K3 is exactly 1 / K1, 1 / K2 and 1 / K3. You have a counter,
and the game is played as follow:

Set the counter to 0 at first.
Roll the 3 dice simultaneously. If the up-facing number of Die1 is a, the up-facing number of Die2 is b and the up-facing number of Die3 is c, set the counter to 0. Otherwise,
add the counter by the total value of the 3 up-facing numbers.
If the counter's number is still not greater than n, go to step 2. Otherwise the game is ended.

Calculate the expectation of the number of times that you cast dice before the end of the game.

Input

There are multiple test cases. The first line of input is an integer T (0 < T <= 300) indicating the number of test cases. Then T test cases follow. Each test case is a line contains 7 non-negative integers n, K1, K2, K3, a, b, c (0
<= n <= 500, 1 < K1, K2, K3 <= 6, 1 <= a <= K1, 1 <= b <= K2, 1 <= c <= K3).

Output

For each test case, output the answer in a single line. A relative error of 1e-8 will be accepted.

Sample Input
2
0 2 2 2 1 1 1
0 6 6 6 1 1 1


Sample Output
1.142857142857143
1.004651162790698


题意:有三个骰子,每个点数1-k[i],甩到每个点数的几率为1/k[i]。 然后有a,b,c,如果第一个骰子投到a,二投到b,三投到c,那么分数清零,否者分数累计。问多少步,可以让分数大于n。

思路来自:http://www.cnblogs.com/jackge/archive/2013/05/21/3091839.html

做法:把n+1 到n+sumk 的dp 都清为0,因为他们不需要步数。 然后 dp
到dp[0] 中 dp[i] 的步数是为∑(dp[i+k]*p)+dp[0]*p+1,(p为1/(k1*k2*k3))。每个式子中都有dp[0],可dp[0]未知。所以设dp[i]=a[i]*dp[0]+b[i], 代入式子中

得 dp[i]=∑(a[i+k]*dp[0]*p+b[i+k]*p)+dp[0]*p+1=a[i]*dp[0]+b[i];

a[i]=∑(a[i+k]*p)+p

b[i]=∑(b[i+k]*p)+1

最后计算得到a[0],b[0],ans=b[0]/(1-a[0]);

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <limits.h>
#include <malloc.h>
#include <ctype.h> 
#include <string>
#include <stack>
#include <iostream>
#include <algorithm>
#include <queue>
using namespace std;  
#define  MAXM 1000000
#define MAXN 110

double a[1000];
double b[1000];
int k[10],abc[10];

int main()
{ 
	int t;
	cin>>t;
	while(t--)
	{
		int n;
		cin>>n;
		int sumk=0;
		double p=1;
		for(int i=0;i<3;i++)
		{	
			cin>>k[i];
			sumk+=k[i];
			p*=(1.0/k[i]);
		}
		for(int i=0;i<3;i++)
		{

			cin>>abc[i];
		}

		for(int i=n+1;i<=n+sumk;i++)
		{
			b[i]=0;
			a[i]=0;
		}

		for(int i=n;i>=0;i--)
		{
			a[i]=0;
			b[i]=0;
			for(int j=1;j<=k[0];j++)
			{
				for(int l=1;l<=k[1];l++)
				{
					for(int m=1;m<=k[2];m++)
					{
						if(j!=abc[0]||l!=abc[1]||m!=abc[2])
						{
							a[i]+=p*(a[j+l+m+i]);

							b[i]+=p*(b[j+l+m+i]); 
						}

					}
				}
			}  
			a[i]+=p;
			b[i]+=1.0;
		} 
		double ans=b[0]/(1-a[0]);
		printf("%.8lf\n",ans,a[0],b[0]); 
	}
	return 0; 
}


思路来自:http://www.cnblogs.com/jackge/archive/2013/05/21/3091839.html
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: