您的位置:首页 > 其它

Sky Code - POJ 3904 容斥原理

2015-04-03 22:32 453 查看
Sky Code

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 1720Accepted: 532
Description

Stancu likes space travels but he is a poor software developer and will never be able to buy his own spacecraft. That is why he is preparing to steal the spacecraft of Petru. There is only one problem – Petru has locked the spacecraft with a sophisticated cryptosystem
based on the ID numbers of the stars from the Milky Way Galaxy. For breaking the system Stancu has to check each subset of four stars such that the only common divisor of their numbers is 1. Nasty, isn’t it? Fortunately, Stancu has succeeded to limit the number
of the interesting stars to N but, any way, the possible subsets of four stars can be too many. Help him to find their number and to decide if there is a chance to break the system.
Input

In the input file several test cases are given. For each test case on the first line the number N of interesting stars is given (1 ≤ N ≤ 10000). The second line of the test case contains the list of ID numbers of the interesting stars, separated by spaces.
Each ID is a positive integer which is no greater than 10000. The input data terminate with the end of file.
Output

For each test case the program should print one line with the number of subsets with the asked property.
Sample Input
4
2 3 4 5 
4
2 4 6 8 
7
2 3 4 5 7 6 8

Sample Output
1 
0 
34


题意:求给定的数有多少个四元组,其最大公约数为1。

思路:首先求出1-10000每个数有多少个它的倍数,然后容斥原理减去奇数个素数组成的最大公约数的四元组,加上偶数的。

AC代码如下:

#include<cstdio>
#include<cstring>
using namespace std;
typedef long long ll;
ll n,num[10010],prime[10010];
ll num_p[10010],ret,p[10010],temp;
bool vis[10010];
ll Cal(ll a)
{
    return a*(a-1)*(a-2)*(a-3)/24;
}
void get_sum(int id,int step,int Num)
{
    int i,j;
    if(step>Num)
    {
        ret+=Cal(num_p[temp]);
        return;
    }
    for(i=id;i<=prime[0];i++)
    {
        if(temp*prime[i]>10000)
          return;
        p[step]=prime[i];
        temp*=prime[i];
        get_sum(i+1,step+1,Num);
        temp/=prime[i];
    }
}
int main()
{
    int i,j,k;
    ll ans;
    for(i=2;i<=10000;i++)
       if(!vis[i])
       {
           prime[++prime[0]]=i;
           for(j=i*2;j<=10000;j+=i)
              vis[j]=1;
       }
    while(~scanf("%I64d",&n))
    {
        memset(num,0,sizeof(num));
        memset(num_p,0,sizeof(num_p));
        for(i=1;i<=n;i++)
        {
            scanf("%d",&k);
            num[k]++;
        }
        for(i=1;i<=10000;i++)
        {
            for(j=i;j<=10000;j+=i)
               num_p[i]+=num[j];
        }
        ans=Cal(n);
        for(i=1;i<=8;i++)
        {
            ret=0;
            temp=1;
            get_sum(1,1,i);
            if(i&1)
              ans-=ret;
            else
              ans+=ret;
        }
        printf("%I64d\n",ans);
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: