您的位置:首页 > 其它

hdu 1548 A strange lift(bfs)

2015-03-23 00:45 447 查看


A strange lift

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 13675 Accepted Submission(s): 5225



Problem Description

There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will
go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors,
and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2
th floor isn't exist.

Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"?



Input

The input consists of several test cases.,Each test case contains two lines.

The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.

A single 0 indicate the end of the input.



Output

For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".



Sample Input

5 1 5
3 3 1 2 5
0




Sample Output

3




Recommend

8600 | We have carefully selected several similar problems for you: 1385 1242 1142 1217 1253



#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdlib>
#include<queue>
#define N 1010
#define ll long long

using namespace std;

int n,A,B;
int a
;
struct node {
    int pos;
    int num;
};
bool vis
;
queue<node>que;
node b;
int ans;

void bfs() {
    ans=-1;
    while(que.size())que.pop();
    memset(vis,0,sizeof vis);
    b.pos=A;
    b.num=0;
    que.push(b);
    vis[A]=1;
    while(que.size()) {
        node t=que.front();
        que.pop();
        if(t.pos==B) {
            ans=t.num;
            break;
        }
        node tt;

        tt.pos=t.pos+a[t.pos];
        tt.num=t.num+1;
        if(tt.pos<=n&&!vis[tt.pos]) {
            que.push(tt);
            vis[tt.pos]=1;
        }

        tt.pos=t.pos-a[t.pos];
        tt.num=t.num+1;
        if(tt.pos>=1&&!vis[tt.pos]) {
            que.push(tt);
            vis[tt.pos]=1;
        }
    }
}

int main() {
    while(cin>>n&&n) {
        cin>>A>>B;
        for(int i=1; i<=n; i++)
            cin>>a[i];
        bfs();
        cout<<ans<<endl;
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: