您的位置:首页 > 其它

【原创】poj ----- 2376 Cleaning Shifts 解题报告

2015-03-22 20:49 477 查看
题目地址:

http://poj.org/problem?id=2376

题目内容:

Cleaning Shifts

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 12226Accepted: 3187
Description

Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T.

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval.

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.
Input

* Line 1: Two space-separated integers: N and T

* Lines 2..N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.
Output

* Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.
Sample Input

3 10
1 7
3 6
6 10

Sample Output

2

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

INPUT DETAILS:

There are 3 cows and 10 shifts. Cow #1 can work shifts 1..7, cow #2 can work shifts 3..6, and cow #3 can work shifts 6..10.

OUTPUT DETAILS:

By selecting cows #1 and #3, all shifts are covered. There is no way to cover all the shifts using fewer than 2 cows.
Source

USACO 2004 December Silver

解题思路:

典型的区间贪心。

首先,我们需要根据线段的起点坐标来排序,小的在前面。
具体实现上,我们需要使用一个变量记住当前需要匹配的shift。所谓当前需要匹配的shift,举一个例子:
比如需要匹配100,那么在第一轮中,当前需要匹配的shift就是1。而选用1 20来匹配后,当前需要匹配的shift就变为21。

遍历排序后的数组,如果能够匹配当前点,记录下终点;如果不能够匹配当前点,就取出最长的终点,作为下一个当前需要匹配的shift。

具体代码:

#include <algorithm>
#include <cstdio>
using namespace std;

int n,t;
struct cow
{
int start;
int fin;
};
cow whole[25001];

bool cmp(const cow& a, const cow& b)
{
return a.start < b.start;
}

int main(void)
{
scanf("%d%d", &n, &t);
for (int i = 0; i < n; i ++) {
int t1,t2;
scanf("%d%d", &t1, &t2);
whole[i].start = t1;
whole[i].fin = t2;
}
sort(whole, whole + n, cmp);
int top = 1;
int max_length = 0;
int res = 0;
for (int i = 0; i < n; i ++) {

if (whole[i].start > top) {
if (max_length == 0) {
res = -1;
break;
} else {
res ++;
top = max_length + 1;
max_length = 0;
if (top > t)
break;
}
}
if (whole[i].start <= top && whole[i].fin >= top && max_length < whole[i].fin) {
max_length = whole[i].fin;
}
//printf("now is %d, top is %d, max is %d\n", i, top, max_length);
}
if (max_length != 0) {
res ++;
top = max_length + 1;
}
if (top <= t)
res = -1;
printf("%d\n", res);
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: