您的位置:首页 > 其它

POJ 3744 Scout YYF I (概率dp+矩阵优化)

2015-03-17 23:07 309 查看
Language:
Default

Scout YYF I

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 5504Accepted: 1522
Description

YYF is a couragous scout. Now he is on a dangerous mission which is to penetrate into the enemy's base. After overcoming a series difficulties, YYF is now at the start of enemy's famous "mine road". This is a very long road, on which there are numbers of mines.
At first, YYF is at step one. For each step after that, YYF will walk one step with a probability of p, or jump two step with a probality of 1-p. Here is the task, given the place of each mine, please calculate the probality that YYF can
go through the "mine road" safely.
Input

The input contains many test cases ended with EOF.

Each test case contains two lines.

The First line of each test case is N (1 ≤ N ≤ 10) and p (0.25 ≤ p ≤ 0.75) seperated by a single blank, standing for the number of mines and the probability to walk one step.

The Second line of each test case is N integer standing for the place of N mines. Each integer is in the range of [1, 100000000].
Output

For each test case, output the probabilty in a single line with the precision to 7 digits after the decimal point.
Sample Input
1 0.5
2
2 0.5
2 4

Sample Output
0.5000000
0.2500000

Source

POJ Monthly Contest - 2009.08.23, Simon

题意:当前点是 1 ,有n个放置的雷,求不踩雷的概率通过

思路: 参照 kuangbin 大神博客 http://www.cnblogs.com/kuangbin/archive/2012/10/02/2710586.html


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>
#include<set>
#include<map>

#define L(x) (x<<1)
#define R(x) (x<<1|1)
#define MID(x,y) ((x+y)>>1)

#define eps 1e-8
typedef __int64 ll;

#define fre(i,a,b)  for(i = a; i <b; i++)
#define free(i,b,a) for(i = b; i >= a;i--)
#define mem(t, v)   memset ((t) , v, sizeof(t))
#define ssf(n)      scanf("%s", n)
#define sf(n)       scanf("%d", &n)
#define sff(a,b)    scanf("%d %d", &a, &b)
#define sfff(a,b,c) scanf("%d %d %d", &a, &b, &c)
#define pf          printf
#define bug         pf("Hi\n")

using namespace std;

#define INF 0x3f3f3f3f
#define N 15

int a
;
int n;
double p;

struct mat{
   double A[3][3];
   mat(){ mem(A,0); }

   mat operator * (mat b)
   {
      mat c;
      int i,j,k;

   	  fre(i,0,3)
   	   fre(j,0,3)
   	   {
            fre(k,0,3)
   	   	     c.A[i][j]+=A[i][k]*b.A[k][j];
   	   }

   	   return c;
   }

}s;

mat pow_mul(mat s,int n)
{
     mat ans;
     int i,j;

     fre(i,0,3)
     	ans.A[i][i]=1;

    while(n)
	{
		if(n&1) ans=ans*s;
		s=s*s;
		n>>=1;
	}

	return ans;
}

int main()
{
	int i,j;

	while(~scanf("%d%lf",&n,&p))
	{
		fre(i,0,n)
		 sf(a[i]);

		 double ans=1;

		 s.A[0][0]=p;
		 s.A[0][1]=1-p;
		 s.A[1][0]=1;
		 s.A[1][1]=0;

		 mat temp;

		 sort(a,a+n);

		 temp=pow_mul(s,a[0]-1);   //计算走到这一个点的概率

		 ans*=(1-temp.A[0][0]);

		 fre(i,1,n)
		 {
		 	 if(a[i]==a[i-1]) continue;
		 	 temp=pow_mul(s,a[i]-a[i-1]-1);
		 	 ans*=(1-temp.A[0][0]);
		 }

       pf("%.7f\n",ans);
	}
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: