您的位置:首页 > 其它

hdoj 1710 Binary Tree Traversals(二叉树的建立及遍历)

2015-03-17 20:30 579 查看

http://acm.hdu.edu.cn/showproblem.php?pid=1710

Binary Tree Traversals

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3896    Accepted Submission(s): 1732


[align=left]Problem Description[/align]
A binary tree is a finite set of vertices that is either empty or consists of a root r and two disjoint binary trees called the left and right subtrees. There are three most important ways in which the vertices of a binary tree can
be systematically traversed or ordered. They are preorder, inorder and postorder. Let T be a binary tree with root r and subtrees T1,T2.

In a preorder traversal of the vertices of T, we visit the root r followed by visiting the vertices of T1 in preorder, then the vertices of T2 in preorder.

In an inorder traversal of the vertices of T, we visit the vertices of T1 in inorder, then the root r, followed by the vertices of T2 in inorder.

In a postorder traversal of the vertices of T, we visit the vertices of T1 in postorder, then the vertices of T2 in postorder and finally we visit r.

Now you are given the preorder sequence and inorder sequence of a certain binary tree. Try to find out its postorder sequence.



 

[align=left]Input[/align]
The input contains several test cases. The first line of each test case contains a single integer n (1<=n<=1000), the number of vertices of the binary tree. Followed by two lines, respectively indicating the preorder sequence and
inorder sequence. You can assume they are always correspond to a exclusive binary tree.

 

[align=left]Output[/align]
For each test case print a single line specifying the corresponding postorder sequence.

 

[align=left]Sample Input[/align]

9
1 2 4 7 3 5 8 9 6
4 7 2 1 8 5 9 3 6

 

[align=left]Sample Output[/align]

7 4 2 8 9 5 6 3 1

//给出二叉树的先序遍历和中序遍历,求后序遍历
// 注: 已知二叉树的前序和中序遍历, 可以唯一确定二叉树的后序遍历, 但如果知道前序和后序,求中序遍历是不可能实现的
#include<stdio.h>
#include<string.h>
#include<malloc.h>
struct Bintree
{
int date;
Bintree *lchild,*rchild;
} *root;
Bintree *CreatTree(int *a,int *b,int n)//建立二叉树
{
struct Bintree *p;
int i;
for(i=0;i<n;i++)
{
if(a[0]==b[i])
{
p=(struct Bintree *)malloc(sizeof(struct Bintree));
p->date=a[0];

p->lchild=CreatTree(a+1,b,i);//左子树
p->rchild=CreatTree(a+1+i,b+1+i,n-1-i);//右子树
return p;
}
}
return NULL;
}
void Post(struct Bintree *head)//后序遍历
{
if(head)
{
Post(head->lchild);
Post(head->rchild);

if(head->date==root->date)
printf("%d\n",head->date);
else
printf("%d ",head->date);
}
}
int main()
{
int n,i;
while(scanf("%d",&n)!=EOF)
{
int *pre=(int *)malloc(sizeof(int)*n);
for(i=0;i<n;i++)
scanf("%d",&pre[i]);
int *in=(int *)malloc(sizeof(int)*n);
for(i=0;i<n;i++)
scanf("%d",&in[i]);

root=CreatTree(pre,in,n);
Post(root);//后续遍历
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: