您的位置:首页 > 其它

HDU 1083--Courses【二分图的最大匹配】

2015-03-17 15:02 375 查看

Courses

Time Limit: 20000/10000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 4146 Accepted Submission(s): 1975



Problem Description
Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions:

. every student in the committee represents a different course (a student can represent a course if he/she visits that course)

. each course has a representative in the committee

Your program should read sets of data from a text file. The first line of the input file contains the number of the data sets. Each data set is presented in the following format:

P N

Count1 Student1 1 Student1 2 ... Student1 Count1

Count2 Student2 1 Student2 2 ... Student2 Count2

......

CountP StudentP 1 StudentP 2 ... StudentP CountP

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses . from course 1 to course P,
each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you'll find the Count i students, visiting the course,
each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.

There are no blank lines between consecutive sets of data. Input data are correct.

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

An example of program input and output:


Sample Input
2
3 3
3 1 2 3
2 1 2
1 1
3 3
2 1 3
2 1 3
1 1




Sample Output
YES
NO




直接套的匈牙利算法的模板

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=310;

int map[maxn][maxn];
int vis[maxn];
int match[maxn];
int P,N;//P:课程,N:学生。

int dfs(int x){//分配课程x对应的学生
    for(int i=1;i<=N;++i){
        if(!vis[i] && map[x][i]){
            vis[i]=1;
            if(!match[i] || dfs(match[i])){
                match[i]=x;
                return 1;
            }
        }
    }
    return 0;
}

int main (){
    int t,i,k,x;
    scanf("%d",&t);
    while(t--){
        memset(map,0,sizeof(map));
        memset(match,0,sizeof(match));
        scanf("%d%d",&P,&N);
        for(i=1;i<=P;++i){
            scanf("%d",&k);
            while(k--){
                scanf("%d",&x);
                map[i][x]=1;
            }
        }
        int ans=0;
        for(i=1;i<=P;++i){
            memset(vis,0,sizeof(vis));
            if(dfs(i)) ans++;
        }
        if(ans==P) printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: