您的位置:首页 > 移动开发 > IOS开发

杭电 acm 1017 A Mathematical Curiosity

2015-03-14 00:17 459 查看

A Mathematical Curiosity

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 29262 Accepted Submission(s): 9316



Problem Description
Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.



Input
You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.



Output
For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.



Sample Input
1

10 1
20 3
30 4
0 0




Sample Output
Case 1: 2
Case 2: 4
Case 3: 5




妈的蛋,我靠 我再是新手 也不能那么坑爹啊 ,wa N*N次 !
靠 题目开始好难理解的样子 m&&n都为零才是一个输入块;题目意思是在0到n中查找多少个a b满足那样的两个条件;注意每个输入块中间有空格;而最后一个没有
#include<iostream>
int main()
{
	using namespace std;
	int N,n,t=0,m,count=0;
	cin>>N;
	while(N--)
	{
		while(cin>>n>>m,n+m)
		{
			count=0;
			for(int i=1;i<n;i++)
			{
				for(int j=i+1;j<n;j++)
				{
					if((i*i+j*j+m)%(i*j)==0)
						count++;
				}
			}
			cout<<"Case "<<++t<<": "<<count++<<endl;
		}
		t=0;
		if(N)
			cout<<endl;
	}
	
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: