您的位置:首页 > 移动开发 > IOS开发

杭电 1017 A Mathematical Curiosity

2013-04-17 11:07 471 查看

A Mathematical Curiosity

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19933 Accepted Submission(s): 6160


[align=left]Problem Description[/align]
Given
two integers n and m, count the number of pairs of integers (a,b) such
that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.

This problem contains multiple test cases!

The
first line of a multiple input is an integer N, then a blank line
followed by N input blocks. Each input block is in the format indicated
in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

[align=left]Input[/align]
You
will be given a number of cases in the input. Each case is specified by
a line containing the integers n and m. The end of input is indicated
by a case in which n = m = 0. You may assume that 0 < n <= 100.

[align=left]Output[/align]
For
each case, print the case number as well as the number of pairs (a,b)
satisfying the given property. Print the output for each case on one
line in the format as shown below.

[align=left]Sample Input[/align]

1

10 1
20 3
30 4
0 0

[align=left]Sample Output[/align]

Case 1: 2

Case 2: 4

Case 3:5

这道题的描述是有一些错误的,但是可能并不像我刚开始想的那么多错误!
问题出在哪儿呢?什么时候应该有空白行,什么时候不应该有,这点很是纠结!刚开始没看明白……
提交了3次,前两次都是PE,最后一次AC,代码如下:

View Code

#include <stdio.h>
#include <stdlib.h>

int main(int argc, char *argv[])
{
int N, i, j, n, m, cnt,sum;
scanf( "%d", &N );
while( N-- )
{
cnt = 0;
while( (scanf( "%d%d", &n, &m )!= EOF)&&(n||m) )
{
cnt++;
sum = 0;
for( i = 2; i < n; i++ )
for( j = 1; j < i; j++ )
if( (i*i+j*j+m)%(i*j)==0 )
sum++;
printf( "Case %d: %d\n", cnt, sum );
}
if( N != 0 )
printf( "\n" );
}

//system("PAUSE");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: