您的位置:首页 > 移动开发 > IOS开发

HDOJ 1017 HDU 1017 A Mathematical Curiosity ACM 1017 IN HDU

2010-09-04 13:29 597 查看
MiYu原创, 转帖请注明 : 转载自 ______________白白の屋


题目地址 :
    http://acm.hdu.edu.cn/showproblem.php?pid=1017

题目描述:

A Mathematical Curiosity

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8614 Accepted Submission(s): 2592


[align=left]Problem Description[/align]Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

[align=left]Input[/align]You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.

[align=left]Output[/align]For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.

[align=left]Sample Input[/align]
1

10 1
20 3
30 4
0 0

[align=left]Sample Output[/align]
Case 1: 2
Case 2: 4
Case 3: 5


题目分析 :

  没事水一水, 嘿嘿....... 新手只需要 注意下输出就可以了 . 暴力过, 没什么技巧

代码如下 :

/*

MiYu原创, 转帖请注明 : 转载自 ______________白白の屋
http://www.cnblog.com/MiYu
Author By : MiYu

Test : 1

Program : 1017

*/

#include <iostream>

#include <algorithm>

using namespace std;

int main ()

{

int T; cin >> T;

for ( int k = 1; k <= T; ++ k ){

int N, M, ca = 1, cnt = 0;

if ( k != 1 ) putchar ( 10 );

while ( cin >> N >> M, N || M ){ cnt = 0;

for ( int i = 1; i < N; ++ i ){

for ( int j = i + 1; j < N; ++ j ){

if ( ( i * i + j * j + M ) % ( i * j ) == 0 )

cnt ++;

}

}

printf ( "Case %d: %d\n",ca++, cnt );

}

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: