您的位置:首页 > 其它

HDOJ 题目2444 The Accomodation of Students(染色法判二分图,最大匹配)

2015-03-12 14:14 513 查看


The Accomodation of Students

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2943 Accepted Submission(s): 1376



Problem Description

There are a group of students. Some of them may know each other, while others don't. For example, A and B know each other, B and C know each other. But this may not imply that A and C know each other.

Now you are given all pairs of students who know each other. Your task is to divide the students into two groups so that any two students in the same group don't know each other.If this goal can be achieved, then arrange them into double rooms. Remember, only
paris appearing in the previous given set can live in the same room, which means only known students can live in the same room.

Calculate the maximum number of pairs that can be arranged into these double rooms.

Input

For each data set:

The first line gives two integers, n and m(1<n<=200), indicating there are n students and m pairs of students who know each other. The next m lines give such pairs.

Proceed to the end of file.

Output

If these students cannot be divided into two groups, print "No". Otherwise, print the maximum number of pairs that can be arranged in those rooms.

Sample Input

4 4
1 2
1 3
1 4
2 3
6 5
1 2
1 3
1 4
2 5
3 6


Sample Output

No
3


Source

2008 Asia Harbin Regional Contest Online

Recommend

gaojie | We have carefully selected several similar problems for you: 2443 2442 2441 2440 2439

ac代码

#include<stdio.h>
#include<string.h>
#include<string>
#include<vector>
#include<iostream>
using namespace std;
int color[205],vis[205],link[205];
int n,m;
vector<int>vt[205];
int dfs(int u,int c)
{
if(color[u]==0)
{
color[u]=c;
}
else
{
if(color[u]==c)
return 0;
return 1;
}
for(int i=0;i<vt[u].size();i++)
{
int v=vt[u][i];
if(dfs(v,-c))
return 1;
}
return 0;
}
int jud()
{
int i;
memset(color,0,sizeof(color));
for(i=1;i<=n;i++)
{
if(!color[i])
if(dfs(i,1))
return 0;
}
return 1;
}
int dfs(int u)
{
for(int i=0;i<vt[u].size();i++)
{
int v=vt[u][i];
if(!vis[v])
{
vis[v]=1;
if(link[v]==-1||dfs(link[v]))
{
link[v]=u;
return 1;
}
}
}
return 0;
}
int main()
{
//int n,m;
while(scanf("%d%d",&n,&m)!=EOF)
{
int i;
for(i=0;i<=n;i++)
vt[i].clear();
for(i=0;i<m;i++)
{
int u,v;
scanf("%d%d",&u,&v);
vt[u].push_back(v);
vt[v].push_back(u);
}
if(!jud())
{
printf("No\n");
continue;
}
int ans=0;
memset(link,-1,sizeof(link));
for(i=1;i<=n;i++)
{
memset(vis,0,sizeof(vis));
if(dfs(i))
ans++;
}
printf("%d\n",ans/2);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐