您的位置:首页 > 其它

hdu 1087 Super Jumping! Jumping! Jumping! (最大递增子序列和)

2015-03-01 16:07 381 查看

Super Jumping! Jumping! Jumping!

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 24527 Accepted Submission(s): 10827



Problem Description
Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.



The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In
the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping
can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his
jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.

Your task is to output the maximum value according to the given chessmen list.



Input
Input contains multiple test cases. Each test case is described in a line as follow:

N value_1 value_2 …value_N

It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.

A test case starting with 0 terminates the input and this test case is not to be processed.



Output
For each case, print the maximum according to rules, and one line one case.



Sample Input
3 1 3 2
4 1 2 3 4
4 3 3 2 1
0




Sample Output
4
10
3

题意:求最大递增子序列和

方法:见博客http://qianmacao.blog.163.com/blog/static/203397180201221074949474/
[code]分析:在序列中对于任意元素都有其最长递增序列,那么对于后续元素其最优解与其他元素最优解的联系是什么呢? 不难知道整体最优解与局部最优解的关系为:dp[i] = max{ dp[j] + a[i] } (0<=j<=i)其中dp[i]表示第i个元素的最长递增子序列和。动态规划详细解析:如序列:1 4 7 3 5 6,那么开一个数组来保存同下标的“最大值”,每一个都要向前找合法的最大s值,如这里的5可以找的合法值为3 4 1,找到最大后便加上同下标的a值,如:数组a:1  4   7   3    5    6数组s:1  5  12   4  10   16这样从数组S就可以找到最大值了。

代码:
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

int a[1005];
int dp[1005];

int max(int a,int b)
{
    return a>b?a:b;
}

int main()
{
    int n;
    int ans;
    while(scanf("%d",&n),n)
    {
        for(int i=1; i<=n; i++)
            scanf("%d",&a[i]);
        ans=dp[1]=a[1];
        for(int i=2; i<=n; i++)
        {
            dp[i]=a[i];
            for(int j=1; j<i; j++)
            {
                if(a[j]<a[i])
                {
                    dp[i]=max(dp[j]+a[i],dp[i]);
                }
            }
            if(ans<dp[i])
                ans=dp[i];
        }
        printf("%d\n",ans);
    }
    return 0;
}


[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐