您的位置:首页 > 其它

Help Me Escape - ZOJ 3640 期望dp

2015-02-27 13:17 411 查看
Help Me Escape

Time Limit: 2 Seconds Memory Limit: 32768 KB

Background

If thou doest well, shalt thou not be accepted? and if thou doest not well, sin lieth at the door. And unto thee shall be his desire, and thou shalt
rule over him.

And Cain talked with Abel his brother: and it came to pass, when they were in the field, that Cain rose up against Abel his brother, and slew him.

And the LORD said unto Cain, Where is Abel thy brother? And he said, I know not: Am I my brother's keeper?

And he said, What hast thou done? the voice of thy brother's blood crieth unto me from the ground.

And now art thou cursed from the earth, which hath opened her mouth to receive thy brother's blood from thy hand;

When thou tillest the ground, it shall not henceforth yield unto thee her strength; a fugitive and a vagabond shalt thou be in the earth.

—— Bible Chapter 4
Now Cain is unexpectedly trapped in a cave with N paths. Due to LORD's punishment, all the paths are zigzag and dangerous. The difficulty of the ith path is ci.
Then we define f as the fighting capacity of Cain. Every day, Cain will be sent to one of the N paths randomly.
Suppose Cain is in front of the ith path. He can successfully take ti days to escape from the cave as long as his fighting capacity f is larger than ci.
Otherwise, he has to keep trying day after day. However, if Cain failed to escape, his fighting capacity would increase ci as the result of actual combat. (A kindly reminder: Cain will never died.)
As for ti, we can easily draw a conclusion that ti is closely related to ci. Let's use the following function to describe their relationship:



After D days, Cain finally escapes from the cave. Please output the expectation of D.

Input

The input consists of several cases. In each case, two positive integers N and f (n ≤ 100, f ≤ 10000) are given in the first line. The second
line includes N positive integers ci (ci ≤ 10000, 1 ≤ i ≤ N)

Output

For each case, you should output the expectation(3 digits after the decimal point).

Sample Input

3 1
1 2 3

Sample Output

6.889


题意:一个人逃脱,每天随机到一个关卡,如果他的能力f>c[i],那么需要ti天才能逃走,否则f+=c[i],然后下一天继续闯关。问他逃脱的天数的期望。

思路:dp[i]表示能力值,如果c[j]<i,dp[i]+=ti/n,否则dp[i]+=(dp[i+c[j]]+1)/n。

AC代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
double dp[10010];
int n,tim[110],c[110];
int main()
{
    int i,j,k,f,f2;
    double ret,ans;
    while(~scanf("%d%d",&n,&f))
    {
        for(i=1;i<=n;i++)
           scanf("%d",&c[i]);
        sort(c+1,c+1+n);
        c[n+1]=c
+1;
        for(i=1;i<=n;i++)
           tim[i]=floor((1+sqrt(5))/2*c[i]*c[i]);
        for(i=max(f,c[n+1]);i>=f;i--)
        {
            ret=0;
            for(j=1;j<=n;j++)
            {
                if(c[j]<i)
                  ret+=1.0*tim[j]/n;
                else
                  ret+=(dp[min(i+c[j],c[n+1])]+1)/n;
            }
            dp[i]=ret;
        }
        printf("%.3f\n",dp[f]);
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: