您的位置:首页 > 其它

POJ 1936 All in All【暴搜】

2015-02-26 11:22 316 查看
All in All

Time Limit: 1000MSMemory Limit: 30000K
Total Submissions: 28817Accepted: 11936
Description

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into
the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.

Input

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.
Output

For each test case output "Yes", if s is a subsequence of t,otherwise output "No".
Sample Input
sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

Sample Output
Yes
No
Yes
No

题意:两个串、 判断第一个串是否为第二个串的子串(不需要连续)。
#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;

char s[100010],t[100010];

int main(){

	int i,j,len1,len2;
	while(cin>>s>>t){
		len1=strlen(s); i=0;
		len2=strlen(t); j=0;
		while(i<len1 && j<len2){
			if(s[i]==t[j]){
				i++; j++;
			}
			else j++;
		}
		if(i==len1)
			cout<<"Yes"<<endl;
		else
			cout<<"No"<<endl;
    }
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: