您的位置:首页 > 其它

Poj 2002 Squares

2015-02-13 13:28 309 查看
Squares

Time Limit: 3500MS Memory Limit: 65536K
Total Submissions: 16889 Accepted: 6414
Description

A square is a 4-sided polygon whose sides have equal length and adjacent sides form 90-degree angles. It is also a polygon such that rotating about its centre by 90 degrees gives the same polygon. It is not the only polygon with the latter property, however,
as a regular octagon also has this property. 

So we all know what a square looks like, but can we find all possible squares that can be formed from a set of stars in a night sky? To make the problem easier, we will assume that the night sky is a 2-dimensional plane, and each star is specified by its x
and y coordinates. 

Input

The input consists of a number of test cases. Each test case starts with the integer n (1 <= n <= 1000) indicating the number of points to follow. Each of the next n lines specify the x and y coordinates (two integers) of each point. You may assume that the
points are distinct and the magnitudes of the coordinates are less than 20000. The input is terminated when n = 0.
Output

For each test case, print on a line the number of squares one can form from the given stars.
Sample Input
4
1 0
0 1
1 1
0 0
9
0 0
1 0
2 0
0 2
1 2
2 2
0 1
1 1
2 1
4
-2 5
3 7
0 0
5 2
0

Sample Output
1
6
1


题意:

有一堆平面散点集,任取四个点,求能组成正方形的不同组合方式有多少。

相同的四个点,不同顺序构成的正方形视为同一正方形。

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

#define MOD 20000

struct node{
int x;
int y;
node *next;
} *head[MOD+1];

int px[2100],py[2100];

int Get_Key(int x,int y){
return (x*x%MOD+y*y%MOD)%MOD;
}

void Get_Hash(int x,int y){
int key=Get_Key(x,y);
node *p=new node;
p->x=x;
p->y=y;
p->next=head[key]->next;
head[key]->next=p;
}

int Find(int x,int y){
int key=Get_Key(x,y);
node *p;
for(p=head[key]->next;p!=NULL;p=p->next){
//cout<<p->x<<'-'<<p->y<<endl;
if(p->x==x&&p->y==y){
//cout<<123<<endl;
return 1;
}
}
return 0;
}

int main(){
int n;
while(scanf("%d",&n)&&n){
int num=0;
for(int i=0;i<=MOD;i++){
head[i]=new node;
head[i]->next=NULL;
}
for(int i=0;i<n;i++){
scanf("%d%d",&px[i],&py[i]);
Get_Hash(px[i],py[i]);
}
for(int i=0;i<n-1;i++){
for(int j=i+1;j<n;j++){
int a=px[j]-px[i];
int b=py[j]-py[i];

int x3=px[i]+b;
int y3=py[i]-a;
int x4=px[j]+b;
int y4=py[j]-a;
//cout<<x3<<' '<<y3<<' '<<x4<<' '<<y4<<endl;
if(Find(x3,y3) && Find(x4,y4)){
num++;
//cout<<num<<endl;
}

x3=px[i]-b;
y3=py[i]+a;
x4=px[j]-b;
y4=py[j]+a;
//cout<<x3<<' '<<y3<<' '<<x4<<' '<<y4<<endl;
if(Find(x3,y3) && Find(x4,y4))
num++;
}
}
cout<<num/4<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: