您的位置:首页 > 其它

POJ-2386-Lake Counting(深度优先搜索初步!)

2015-02-10 14:20 309 查看
Lake Counting

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 21763Accepted: 10962
Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure
out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John's field, determine how many ponds he has.
Input

* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.
Output

* Line 1: The number of ponds in Farmer John's field.
Sample Input
10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output
3

Hint

OUTPUT DETAILS:

There are three ponds: one in the upper left, one in the lower left,and one along the right side.
Source

USACO 2004 November

题目的大概意思是:

有一个大小为N*M的园子,雨后起了水。八连通的积水被认为是连接在一起的。请求出园子里总共有多少水洼?

(八连通指的的是下图中相对W的.的部分)

. . .

. w .

. . .

限制条件

N,M<=100

首先理解八连通的意义!

八向连通(八连通)区域指的是从区域内每一象素出发,可通过八个方向,即上、下、左、右、左上、右上、左下、右下这八个方向的移动的组合,在不越出区域的前提下,到达区域内的任意象素。

我们DFS的思路很简单,从任意的W开始,不停地把邻接的部分用'.'代替。1次DFS后与初始的这个W连接的所有W就被替换成了'.',因此直到途中不再存在W为止,总共DFS的次数就是答案了。8个方向共对应了8种状态转移,每个格子作为DFS的参数至多被调用一次,所以复杂度为O(8*N*M)=O(N*M)。

#include<iostream>
#include<cstdio>
using namespace std;
int N,M;
char field[105][106];
void dfs(int x,int y)
{
field[x][y]='.';
for(int dx=-1;dx<=1;dx++)
{
for(int dy=-1;dy<=1;dy++)
{
int nx=x+dx,ny=y+dy;
if(0<=nx&&nx<N&&0<=ny&&ny<M&&field[nx][ny]=='W')
dfs(nx,ny);
}
}
return;
}
int main()
{
int res=0;
scanf("%d%d",&N,&M);
for(int i=0;i<N;i++)
{
scanf("%s",field[i]);
}
for(int i=0;i<N;i++)
{
for(int j=0;j<M;j++)
{
if(field[i][j]=='W')
{
dfs(i,j);
res++;
}
}
}
cout<<res<<endl;
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: