您的位置:首页 > 其它

(hdu step 2.3.1)A + B Problem II(大数加法)

2015-02-03 10:26 381 查看
题目:
        

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2372 Accepted Submission(s): 917
 
[align=left]Problem Description[/align]I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B. 
[align=left]Input[/align]The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000. 
[align=left]Output[/align]
            For each test case, you should output two lines. The first line is \\\\\\\"Case #:\\\\\\\", # means the number of the test case. The second line is the an equation \\\\\\\"A + B = Sum\\\\\\\", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases. 
[align=left]Sample Input[/align]
2
1 2
112233445566778899 998877665544332211
 
[align=left]Sample Output[/align]
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
 
[align=left]Author[/align]Ignatius.L 
题目分析:
                简单题。这种题比赛的时候直接用java写就好,用C/C++来做其实也是那么个意思。java的BigInteger的相关类底层就是那么实现的。所以没必要写那么1、200,行代码。无论是开发也好,还是算法也好,个人觉得都应该选择最合适的方法来解决问题,而不要拘泥于某种技术。当然,C/C++关于大数的思想还是得看一下的,对于初学者来说,理解后自己敲一遍也是有必要的。但是过了初学阶段的话,个人觉得直接用java来做就好了。

代码如下:
import java.math.BigInteger;
import java.util.Scanner;

public class Main {

public static void main(String[] args) {
Scanner scanner = new Scanner(System.in);

int n = scanner.nextInt();
int i;
for(i = 1 ; i <= n ; ++i){
System.out.println("Case "+ i +":");

BigInteger a = scanner.nextBigInteger();
BigInteger b = scanner.nextBigInteger();

System.out.println(a+" + " + b + " = " + a.add(b));
if(i != n){//最后一个不要出现空行,否则会PE
System.out.println();
}
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: