您的位置:首页 > 其它

uva 10340 All in All(字符串处理)

2015-02-01 11:52 295 查看

uva 10340 All in All

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings
are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.

Given two strings s and t, you have to decide whether
s is a subsequence of t, i.e. if you can remove characters from
t such that the concatenation of the remaining characters is s.

Input Specification
The input contains several testcases. Each is specified by two strings
s, t of alphanumeric ASCII characters separated by whitespace. Input is terminated by EOF.

Output Specification
For each test case output, if s is a subsequence of
t.
Sample Input
sequence subsequence

person compression

VERDI vivaVittorioEmanueleReDiItalia

caseDoesMatter CaseDoesMatter

Sample Output
Yes

No

Yes

No


题目大意:给出两个字符串,判断串1是否为串2的子串,这里的子串不要求在串2中连续,但是要保证顺序一致。

解题思路:一个一个比。

#include<stdio.h>
#include<string.h>
char A[100000], B[100000];
int main() {
	while (scanf("%s %s\n", A, B) == 2) {
		int lenA = strlen(A);
		int lenB = strlen(B);
		int j = 0, i;
		for (i = 0; i < lenA, j < lenB;) {
				if (A[i] == B[j]) {
					j++;
					i++;
				}
				else {
					j++;
				}
		}
		if (i == lenA) printf("Yes\n");
		else printf("No\n");
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: