您的位置:首页 > 其它

uva 101 The Blocks Problem (模拟)

2015-02-03 17:01 441 查看

uva 101 The Blocks Problem

Background

Many areas of Computer Science use simple, abstract domains for both analytical and empirical studies. For example, an early AI study of planning and robotics (STRIPS) used a block world in which a robot arm performed tasks involving the manipulation of blocks.

In this problem you will model a simple block world under certain rules and constraints. Rather than determine how to achieve a specified state, you will ``program'' a robotic arm to respond to a limited set of commands.

The Problem

The problem is to parse a series of commands that instruct a robot arm in how to manipulate blocks that lie on a flat table. Initially there are
n blocks on the table (numbered from 0 to n-1) with block bi adjacent to block
bi+1 for all

as shown in the diagram below:


Figure: Initial Blocks World

The valid commands for the robot arm that manipulates blocks are:

move a onto b
where a and b are block numbers, puts block a onto block
b after returning any blocks that are stacked on top of blocks a and
b to their initial positions.

move a over b
where a and b are block numbers, puts block a onto the top of the stack containing block
b, after returning any blocks that are stacked on top of block a to their initial positions.

pile a onto b
where a and b are block numbers, moves the pile of blocks consisting of block
a, and any blocks that are stacked above block a, onto block
b. All blocks on top of block b are moved to their initial positions prior to the pile taking place. The blocks stacked above block
a retain their order when moved.

pile a over b
where a and b are block numbers, puts the pile of blocks consisting of block
a, and any blocks that are stacked above block a, onto the top of the stack containing block
b. The blocks stacked above block a retain their original order when moved.

quit
terminates manipulations in the block world.

Any command in which a = b or in which a and b are in the same stack of blocks is an illegal command. All illegal commands should be ignored and should have no affect on the configuration of blocks.

The Input

The input begins with an integer n on a line by itself representing the number of blocks in the block world. You may assume that 0 <
n < 25.
The number of blocks is followed by a sequence of block commands, one command per line. Your program should process all commands until the
quit command is encountered.

You may assume that all commands will be of the form specified above. There will be no syntactically incorrect commands.

The Output

The output should consist of the final state of the blocks world. Each original block position numbered
i (

where
n is the number of blocks) should appear followed immediately by a colon. If there is at least a block on it, the colon must be followed by one space, followed by a list of blocks that appear stacked in that position with each block number separated
from other block numbers by a space. Don't put any trailing spaces on a line.

There should be one line of output for each block position (i.e., n lines of output where
n is the integer on the first line of input).

Sample Input

10
move 9 onto 1
move 8 over 1
move 7 over 1
move 6 over 1
pile 8 over 6
pile 8 over 5
move 2 over 1
move 4 over 9
quit

Sample Output

0: 0
 1: 1 9 2 4
 2:
 3: 3
 4:
 5: 5 8 7 6
 6:
 7:
 8:
 9:


题目大意:比较繁琐的一题。有四种情况:

1.move a onto b:将a和b上的方块都清空,将a移到b上。

2.move a over b:将a上的方块清空,将a移到b上(移到b所在方块组的最上方)

3.pile a onto b:将b上方方块清空,将a以及a上方所有方块按原顺序移到b上。

4.pile a over b:将a以及a上方所有方块按原有顺序移到b方块所在方块组最上方。

PS:当a等于b,或两方块在同一方块组,视为非法,不作任何操作。

解题思路:按照思路模拟,需要细心。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int block[30][30], n;
int findx(int m) {
	for (int i = 0; i < n; i++) { 
		for (int j = 0; j < n; j++) {
			if (block[i][j] == m) {
				return i;
			}
		}
	}
	return 0;
}
void find(int m, int &a, int &b) {
	for (int i = 0; i < n; i++) {
		for (int j = 0; j < n; j++) {
			if (block[i][j] == 0) break;
			if (block[i][j] == m) {
				a = i;
				b = j;
				return;
			}
		}
	}	
}
void Return(int m, int &x, int &y) {
	int temp;
	find(m, x, y);
	for (int i = y + 1; block[x][i] != 0; i++) {
		temp = block[x][i];
		block[x][i] = 0;
		block[temp - 1][0] = temp;
	}
}
void mo(int a, int b) {
	int x1, y1, x2, y2;
	if (findx(a) == findx(b)) return;
	Return(a, x1, y1);
	Return(b, x2, y2);
	block[x2][y2 + 1] = a;
	block[x1][y1] = 0;
}
void mv(int a, int b) {
	int x1, y1, x2, y2, i;
	if (findx(a) == findx(b)) return;
	Return(a, x1, y1);
	find(b, x2, y2);
	for (i = y2 + 1; block[x2][i] != 0; i++);
	block[x2][i] = a;
	block[x1][y1] = 0;
}
void po(int a, int b) {
	int x1, y1, x2, y2;
	if (findx(a) == findx(b)) return;
	Return(b, x2, y2);
	find(a, x1, y1);
	for (int i = y1; block[x1][i] != 0; i++) {
		block[x2][++y2] = block[x1][i];
		block[x1][i] = 0;
	}
}
void pv(int a, int b) {
	int x1, y1, x2, y2, i;
	if (findx(a) == findx(b)) return;
	find(a, x1, y1);
	find(b, x2, y2);
	for (i = y2 + 1; block[x2][i] != 0; i++);
	for (int j = y1; block[x1][j] != 0; j++) {
		block[x2][i++] = block[x1][j];
		block[x1][j] = 0;
	}
}
int main() {
	scanf("%d\n", &n);   
	memset(block, 0, sizeof(block));	
	for (int i = 0; i < n; i++) {
		block[i][0] = i + 1;
	}
	int a, b;
	char ch[10], order[10];
	while (scanf("%s", ch) == 1, ch[0] != 'q') {
		scanf("%d %s %d", &a, order, &b);
		if (a == b) continue;
		a++; b++;
		if (strcmp(ch, "move") == 0) {
			if (strcmp(order, "onto") == 0) {
				mo(a, b);					
			}
			else {
				mv(a, b);
			}
		}
		else {
			if (strcmp(order, "onto") == 0) {
				po(a, b);
			}
			else {
				pv(a, b);
			}
		}
	}
	for (int i = 0; i < n; i++) {
		printf("%d:", i);
		for (int j = 0; block[i][j] != 0; j++) {
			printf(" %d", block[i][j] - 1);
		}
		printf("\n");
	}

	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: