您的位置:首页 > 其它

POJ 题目2377 Bad Cowtractors(最大生成树)

2015-01-30 22:21 411 查看
Bad Cowtractors

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 10952Accepted: 4619
Description

Bessie has been hired to build a cheap internet network among Farmer John's N (2 <= N <= 1,000) barns that are conveniently numbered 1..N. FJ has already done some surveying, and found M (1 <= M <= 20,000) possible connection routes between pairs of barns.
Each possible connection route has an associated cost C (1 <= C <= 100,000). Farmer John wants to spend the least amount on connecting the network; he doesn't even want to pay Bessie.

Realizing Farmer John will not pay her, Bessie decides to do the worst job possible. She must decide on a set of connections to install so that (i) the total cost of these connections is as large as possible, (ii) all the barns are connected together (so that
it is possible to reach any barn from any other barn via a path of installed connections), and (iii) so that there are no cycles among the connections (which Farmer John would easily be able to detect). Conditions (ii) and (iii) ensure that the final set of
connections will look like a "tree".
Input

* Line 1: Two space-separated integers: N and M

* Lines 2..M+1: Each line contains three space-separated integers A, B, and C that describe a connection route between barns A and B of cost C.
Output

* Line 1: A single integer, containing the price of the most expensive tree connecting all the barns. If it is not possible to connect all the barns, output -1.
Sample Input
5 8
1 2 3
1 3 7
2 3 10
2 4 4
2 5 8
3 4 6
3 5 2
4 5 17

Sample Output
42

Hint

OUTPUT DETAILS:

The most expensive tree has cost 17 + 8 + 10 + 7 = 42. It uses the following connections: 4 to 5, 2 to 5, 2 to 3, and 1 to 3.
Source

USACO 2004 December Silver

ac代码

#include<stdio.h>
#include<string.h>
int map[1010][1010],v[1010];
int n,m;
void prim()
{
int i,j,ans=0;
memset(v,0,sizeof(v));
v[1]=1;
for(i=1;i<n;i++)
{
int min=-1;
int k=-1;
for(j=1;j<=n;j++)
{
if(!v[j]&&map[1][j]>min)
{
k=j;
min=map[1][j];
}
}
if(k==-1)
break;
ans+=map[1][k];
v[k]=1;
for(j=1;j<=n;j++)
{
if(!v[j]&&map[1][j]<map[k][j])
map[1][j]=map[k][j];
}
}
if(i<n)
printf("-1\n");
else
printf("%d\n",ans);
}
int main()
{
//int n,m;
while(scanf("%d%d",&n,&m)!=EOF)
{
int i,j;
memset(map,-1,sizeof(map));
for(i=0;i<m;i++)
{
int a,b,c;
scanf("%d%d%d",&a,&b,&c);
if(c>map[a][b])
map[a][b]=map[b][a]=c;
}
prim();
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: