您的位置:首页 > 其它

Bad Cowtractors POJ - 2377(最大生成树)

2017-03-31 15:16 417 查看
最大生成树的思路很简单就是把排序的方向变一下优先选择cost大的路径建树就可以了

Bessie has been hired to build a cheap internet network among Farmer John's N (2 <= N <= 1,000) barns that are conveniently numbered 1..N. FJ has already done some surveying, and found M (1 <= M <= 20,000) possible connection routes between pairs of barns.
Each possible connection route has an associated cost C (1 <= C <= 100,000). Farmer John wants to spend the least amount on connecting the network; he doesn't even want to pay Bessie.

Realizing Farmer John will not pay her, Bessie decides to do the worst job possible. She must decide on a set of connections to install so that (i) the total cost of these connections is as large as possible, (ii) all the barns are connected together (so that
it is possible to reach any barn from any other barn via a path of installed connections), and (iii) so that there are no cycles among the connections (which Farmer John would easily be able to detect). Conditions (ii) and (iii) ensure that the final set of
connections will look like a "tree".

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..M+1: Each line contains three space-separated integers A, B, and C that describe a connection route between barns A and B of cost C.

Output

* Line 1: A single integer, containing the price of the most expensive tree connecting all the barns. If it is not possible to connect all the barns, output -1.

Sample Input

5 8

1 2 3

1 3 7

2 3 10

2 4 4

2 5 8

3 4 6

3 5 2

4 5 17

Sample Output

42

Hint

OUTPUT DETAILS:

The most expensive tree has cost 17 + 8 + 10 + 7 = 42. It uses the following connections: 4 to 5, 2 to 5, 2 to 3, and 1 to 3.

#include <iostream>
#include <cstdio>
#include <string>
#include <algorithm>
using namespace std;
int v,e;
const int maxn = 200005;
struct edge
{
int from,t
4000
o,cost;
};
edge es[maxn];
int father[maxn];
int Find(int s)
{
return father[s]==s?s:father[s]=Find(father[s]);
}
void Union (int a,int b)
{
a=Find(a);
b=Find(b);
if(a!=b) father[a]=b;
}
bool same (const edge &t1)
{
return Find(t1.from)==Find(t1.to);
}
bool cmp(const edge &t1,const edge &t2)
{
return t1.cost>t2.cost;
}
int res;
bool Kruskal()
{
for(int i=0; i<=v; i++) father[i]=i;
sort(es,es+e,cmp);

int sum=0;
for(int i=0; i<e; i++)
{
edge e=es[i];

if(!same(e))
{
res+=e.cost;
sum++;
Union(e.from,e.to);

}
// if(sum==v-1) break;
}
return sum==v-1;
}
int main()
{
scanf("%d%d",&v,&e);
res=0;
for(int i=0; i<e; i++)
{
scanf("%d%d%d",&es[i].from,&es[i].to,&es[i].cost);
}
if(Kruskal())
printf("%d\n",res);
else printf("-1\n");
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: