您的位置:首页 > 其它

hdu 1059 Dividing 多重背包

2015-01-26 16:18 302 查看
Dividing

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 18296 Accepted Submission(s): 5100

Problem Description

Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in
half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the
same total value.

Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets
of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.



Input

Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2
0 0''. The maximum total number of marbles will be 20000.

The last line of the input file will be ``0 0 0 0 0 0''; do not process this line.



Output

For each colletcion, output ``Collection #k:'', where k is the number of the test case, and then either ``Can be divided.'' or ``Can't be divided.''.

Output a blank line after each test case.



Sample Input

1 0 1 2 0 0

1 0 0 0 1 1

0 0 0 0 0 0



Sample Output

Collection #1:

Can't be divided.

Collection #2:

Can be divided.

把题目的value 当作 cost。

初始化 dp[0] =1 。

然后模版一套就好了。取v/2为容量 ,不然会超时。

#include<stdio.h>
#include<string.h>
#define N 10 //件数
#define NN 30000*6  //件数乘价格乘数量
int dp[NN],i,k,v;
void bag01(int cost)
{
	for(i=v;i>=cost;i--)
		dp[i]+=dp[i-cost];
}
void complete(int cost)
{
	for(i=cost;i<=v;i++) 
		dp[i]+=dp[i-cost];
}
void multiply(int cost,int amount)
{
	if(cost*amount>=v)
		complete(cost);
	else{
		k=1;
		while(k<amount){  //k分成1 2 4 8 16 个  二进制数,可以代表所有情况. 
			bag01(k*cost);
			amount-=k;
			k+=k;
		}
		if(amount!=0)
		bag01(cost*amount);
	}
}
int main()
{
	int n,w
,num
,cost
,j;
	int cas=1;
	int sum;
	while(scanf("%d",&num[1])!=EOF){
		memset(dp,0,sizeof(dp));
		dp[0]=1;
		sum=0;
		sum+=num[1];
		cost[1]=1;
		for(j=2;j<=6;j++){
			scanf("%d",&num[j]);
			cost[j]=j;
			sum+=num[j]*j;
		}
		if(sum==0)
			break;

		v=sum/2;
		if(sum%2==0)
		for(j=1;j<=6;j++)
			multiply(cost[j],num[j]); 
		
		printf("Collection #%d:\n",cas++);
		if(dp[v]==0||sum%2==1)
			printf("Can't be divided.\n");
		else 
			printf("Can be divided.\n");
		puts("");
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: