您的位置:首页 > 产品设计 > UI/UE

UVA 10420-List of Conquests(STL-map的应用)

2015-01-02 17:32 357 查看
List of Conquests
Time Limit:3000MS Memory Limit:0KB 64bit IO Format:%lld & %llu
Submit Status

Description




Problem B

List of Conquests

Input:
standard input

Output:
standard output

Time Limit:
2 seconds
In Act I, Leporello is telling Donna Elvira about his master's long list of conquests:
``This is the list of the beauties my master has loved, a list I've made out myself: take a look, read it with me. In Italy six hundred and forty, in Germany two hundred and thirty-one, a hundred in France, ninety-one in Turkey; but in Spain already a thousand
and three! Among them are country girls, waiting-maids, city beauties; there are countesses, baronesses, marchionesses, princesses: women of every rank, of every size, of every age.'' (Madamina, il catalogo è questo)

As Leporello records all the ``beauties'' Don Giovanni ``loved'' in chronological order, it is very troublesome for him to present his master's conquest to others because he needs to count the number of ``beauties'' by their nationality
each time. You are to help Leporello to count.

Input

The input consists of at most 2000 lines, but the first. The first line contains a number n, indicating that there will be n more lines. Each following line, with at most 75 characters,
contains a country (the first word) and the name of a woman (the rest of the words in the line) Giovanni loved. You may assume that the name of all countries consist of only one word.

Output

The output consists of lines in alphabetical order. Each line starts with the name of a country, followed by the total number of women Giovanni loved in that country, separated by a space.

Sample Input

3

Spain Donna Elvira

England Jane Doe

Spain Donna Anna

Sample Output

England 1

Spain 2

题意:一个富豪在n个地方有情妇,第一个单词是国家,后面跟着的是人名。问每个国家里面情妇的人数。

小技巧:当用scanf输入字符串的时候不能包含空格,gets输入字符串的时候可以包含空格。

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#include <map>
#include <string>
using namespace std;
int main()
{
int n;
char country[110];
char woman[110];
map<string,int >G;
map<string,int >::iterator it;
scanf("%d",&n);
while(n--)
{
scanf("%s",country);
gets(woman);
G[country]++;
}
for(it=G.begin();it!=G.end();it++)
{
cout<<it->first<<' '<<it->second<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: