您的位置:首页 > 其它

UVA 156-Ananagrams(字符串排序按序输出无重复单词)

2015-01-03 15:46 387 查看
Ananagrams
Time Limit:3000MS Memory Limit:0KB 64bit IO Format:%lld
& %llu
Submit Status

Description







Ananagrams

Most crossword puzzle fans are used to anagrams--groups of words with the same letters in different orders--for example OPTS, SPOT, STOP, POTS and POST. Some words however do not have this attribute,
no matter how you rearrange their letters, you cannot form another word. Such words are called ananagrams, an example is QUIZ.

Obviously such definitions depend on the domain within which we are working; you might think that ATHENE is an ananagram, whereas any chemist would quickly produce ETHANE. One possible domain would be the entire
English language, but this could lead to some problems. One could restrict the domain to, say, Music, in which case SCALE becomes a relative ananagram (LACES is not in the same domain) but NOTE is not since it can produce TONE.

Write a program that will read in the dictionary of a restricted domain and determine the relative ananagrams. Note that single letter words are, ipso facto, relative ananagrams since they cannot be ``rearranged''
at all. The dictionary will contain no more than 1000 words.

Input

Input will consist of a series of lines. No line will be more than 80 characters long, but may contain any number of words. Words consist of up to 20 upper and/or lower case letters, and will not be broken across
lines. Spaces may appear freely around words, and at least one space separates multiple words on the same line. Note that words that contain the same letters but of differing case are considered to be anagrams of each other, thus tIeD and EdiT are anagrams.
The file will be terminated by a line consisting of a single #.

Output

Output will consist of a series of lines. Each line will consist of a single word that is a relative ananagram in the input dictionary. Words must be output in lexicographic (case-sensitive) order. There will
always be at least one relative ananagram.

Sample input

ladder came tape soon leader acme RIDE lone Dreis peat
ScAlE orb  eye  Rides dealer  NotE derail LaCeS  drIed
noel dire Disk mace Rob dries
#


Sample output

Disk
NotE
derail
drIed
eye
ladder
soon


题意:把每个单词全部转化成小写字母,对每个单词,看它的字母重排后得到的单词在所有输入的单词中是否出现过,若没有出现,就输出原单词。所有要输出的单词按字典序排列输出。

思路:将所有输入单词存储并排序,将所有字母转化为小写另外存储,对另外存储的每个单词排序。再对另外存储并排序的单词搜一遍,看每个单词是否只出现一次,出现一次,就将对应的原单词输出。

PS:真心受不了,不会用sort对字符串排序,又重新学的用qsort对字符串排序。

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <iostream>
using namespace std;
char str[110][30];
char rep[110][30];
int cmp_char(const void *a,const void *b)//对字母进行排序
{
return *(char *)a-*(char *)b;
}
int cmp_string(const void *a,const void *b)//对单词进行排序
{
return strcmp((char *)a,(char *)b);
}
int main()
{
int i,j;
int cnt=0;
int len;
int sum;
char a[30];
while(~scanf("%s",a))
{
if(a[0]=='#')
break;
strcpy(str[cnt++],a);
}
qsort(str,cnt,sizeof(str[0]),cmp_string);
memset(rep,0,sizeof(rep));
for(i=0; i<cnt; i++)
{
len=strlen(str[i]);
for(j=0; j<len; j++)
{
if(str[i][j]>='A'&&str[i][j]<='Z')
rep[i][j]=str[i][j]+32;
else
rep[i][j]=str[i][j];
}
qsort(rep[i],len,sizeof(char),cmp_char);
}
for(i=0;i<cnt;i++)
{
sum=0;
for(j=0;j<cnt;j++)
if(strcmp(rep[i],rep[j])==0)
sum++;
if(sum==1)
printf("%s\n",str[i]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: