您的位置:首页 > 其它

NYOJ - 715 - Adjacent Bit Counts --第六届河南省程序设计大赛 (DP!!)

2014-12-26 10:51 344 查看

Adjacent Bit Counts

时间限制:1000 ms | 内存限制:65535 KB
难度:4

描述
For a string of n bits x1, x2, x3, …, xn, the adjacent bit count of the string is given by fun(x) = x1*x2 + x2*x3 + x3*x 4 + … + xn-1*x n

which counts the number of times a 1 bit is adjacent to another 1 bit. For example:
Fun(011101101) = 3
Fun(111101101) = 4
Fun (010101010) = 0
Write a program which takes as input integers n and p and returns the number of bit strings x of n bits (out of 2ⁿ) that satisfy Fun(x) = p.

For example, for 5 bit strings, there are 6 ways of getting fun(x) = 2:
11100, 01110, 00111, 10111, 11101, 11011
输入On the first line of the input is a single positive integer k, telling the number of test cases to follow. 1 ≤ k ≤ 10 Each case is a single line that contains a decimal integer giving the number (n) of bits in the bit strings, followed by a single space,
followed by a decimal integer (p) giving the desired adjacent bit count. 1 ≤ n , p ≤ 100输出For each test case, output a line with the number of n-bit strings with adjacent bit count equal to p.样例输入
2


5 2


20 8

样例输出
663426

来源第六届河南省程序设计大赛

简单DP题。。

定义数组dp[105][105][2];其中dp[i][j][0]代表第j位是0的时候长度为j的串组成值为i的串的种数,dp[i][j][1]代表
j位是1的时候长度为j的串组成值为i的串的种数,
容易看出dp[i][j][0]=dp[i][j-1][0]+dp[i][j-1][1]; dp[i][j][1]=dp[i-1][j-1][1]+dp[i][j-1][0];
所以,初始化先把f的值全部赋成0.然后dp[0][1][0]=dp[0][1][1]=1;然后再求出所有dp[0][j][0]和dp[0][j][1]的值;
之后两个for循环就ok了!

AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

long long dp[105][105][2];

void init()
{
	memset(dp, 0, sizeof(dp));
	dp[0][1][0] = 1;
	dp[0][1][1] = 1;
	for(int i=2; i<=100; i++)
	{
		dp[0][i][0] = dp[0][i-1][0] + dp[0][i-1][1];
		dp[0][i][1] = dp[0][i-1][0];
	}
	for(int i=1; i<=100; i++)
		for(int j=2; j<=100; j++)
		{
			dp[i][j][0] = dp[i][j-1][1] + dp[i][j-1][0];
			dp[i][j][1] = dp[i-1][j-1][1] + dp[i][j-1][0];
		}
}
 
int main()
{
	init();
	int k, n, p;
	scanf("%d", &k);
	while(k--)
	{
		scanf("%d %d", &n, &p);
		printf("%I64d\n", dp[p]
[0]+dp[p]
[1]);	
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: