您的位置:首页 > 其它

NYOJ - 716 - River Crossing --第六届河南省程序设计大赛 (简单DP!!)

2014-12-26 10:15 453 查看

River Crossing

时间限制:1000 ms | 内存限制:65535 KB
难度:4

描述
Afandi is herding N sheep across the expanses of grassland when he finds himself blocked by a river. A single raft is available for transportation.

Afandi knows that he must ride on the raft for all crossings, but adding sheep to the raft makes it traverse the river more slowly.

When Afandi is on the raft alone, it can cross the river in M minutes When the i sheep are added, it takes Mi minutes longer to cross the river than with i-1 sheep (i.e., total M+M1 minutes with one sheep, M+M1+M2 with two, etc.).

Determine the minimum time it takes for Afandi to get all of the sheep across the river (including time returning to get more sheep).
输入On the first line of the input is a single positive integer k, telling the number of test cases to follow. 1 ≤ k ≤ 5 Each case contains:

* Line 1: one space-separated integers: N and M (1 ≤ N ≤ 1000 , 1≤ M ≤ 500).

* Lines 2..N+1: Line i+1 contains a single integer: Mi (1 ≤ Mi ≤ 1000)

输出For each test case, output a line with the minimum time it takes for Afandi to get all of the sheep across the river.样例输入
2


2 10


3


5


5 10


3


4


6


100


1

样例输出
18


50

来源第六届河南省程序设计大赛

题意:有1个人和N只羊要过河。一个人单独过河花费的时间是M,每次带一只羊过河花费时间M+M1,带两

羊过河花费时间M+M1+M2……给出N、M和Mi,问N只羊全部过河最少花费的时间是多少。

思路:dp[i]表示一个人和i只羊过河所花费的最短时间,首先dp[0] = m, dp[i] = dp[i-1] + time, 以后更

时,dp[i] = min(dp[i],dp[i-j] + m + dp[j]),j从1循环到i-1,即把i只羊分成两个阶段来运,只需求出

两个阶段的和,然后加上人从对岸回来所用的时间,与dp[i]进行比较,取最小值。

AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int dp[1005];

int main()
{
	int k, n, m;
	scanf("%d", &k);
	while(k--)
	{
		scanf("%d %d", &n, &m);
		dp[0] = m;
		int a;
		for(int i=1; i<=n; i++)
		{
			scanf("%d", &a);
			dp[i] = dp[i-1] + a;
		}
		for(int i = 1; i<=n; i++)
			for(int j=1; j<i; j++)
				dp[i] = min(dp[i], dp[i-j]+dp[j]+m);
		printf("%d\n", dp
);
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: