您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之求二叉树后序遍历和层次遍历

2014-11-23 11:17 183 查看


数据结构实验之求二叉树后序遍历和层次遍历



Time Limit: 1000MS Memory limit: 65536K


题目描述

已知一棵二叉树的前序遍历和中序遍历,求二叉树的后序遍历。


输入

输入数据有多组,第一行是一个整数t (t<1000),代表有t组测试数据。每组包括两个长度小于50 的字符串,第一个字符串表示二叉树的先序遍历序列,第二个字符串表示二叉树的中序遍历序列。


输出

每组第一行输出二叉树的后序遍历序列,第二行输出二叉树的层次遍历序列


示例输入

2
abdegcf
dbgeafc
xnliu
lnixu



示例输出

dgebfca
abcdefg
linux
xnuli



#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
using namespace std;
struct node
{
char data;
struct node *left,*right;
};
struct node *creat(int n,char *str1,char *str2)//建立二叉树
{
int i;
struct node *root;
if(n==0)
return NULL;
root=(struct node *)malloc(sizeof(struct node));
root->data=str1[0];
for(i=0;i<n;i++)
{
if(str2[i]==str1[0])
break;
}
root->left=creat(i,str1+1,str2);
root->right=creat(n-i-1,str1+i+1,str2+i+1);
return root;
};
void houxu(struct node *root)//二叉树的后序遍历
{
if(root!=NULL)
{
houxu(root->left);
houxu(root->right);
cout<<root->data;
}
}
void cengci(struct node *root)//二叉树的层次遍历
{
int cnt=0;
int r1=1;
struct node *p[60];
p[0]=root;
while(cnt<r1)//每一个p[cnt]都是子数的根
{
if(p[cnt])//二叉树最多有两个子树,只有当二叉树不为空时,输出数据
{
cout<<p[cnt]->data;
p[r1++]=p[cnt]->left;
p[r1++]=p[cnt]->right;
}
cnt++;
}
}
int main()
{
int n,len;
struct node *root;
root=(struct node *)malloc(sizeof(struct node));
char str1[60],str2[60];
while(cin>>n)
{
while(n--)
{
cin>>str1>>str2;
len=strlen(str1);
root=creat(len,str1,str2);
houxu(root);
cout<<endl;
cengci(root);
cout<<endl;
}
}
return 0;
}




内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: