您的位置:首页 > 其它

pat 1008. Elevator

2014-10-24 10:05 169 查看
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to
move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.
Sample Input:
3 2 3 1

Sample Output:
41

#include <stdio.h>
#include <stdlib.h>

int main()
{
//freopen("F:/CppProject/data/1008.txt","r",stdin);
int req[102];
int n,current=0,next=0;
int time=0,direction=1;//direction=1 means up,and -1 means down
scanf("%d",&n);
time+=n*5;
for(int i=0;i<n;i++)
{
scanf("%d",&req[i]);
}
req
=req[n-1];//在请求的最后一位后面增加一个数,便于程序的处理
int p=0;
while(p<n)
{
while((req[p+1]-req[p])*direction>0)
{
p++;
}
if(direction==1)
{
time+=((req[p]-current)*6*direction);
current=req[p];
}
else
{
time+=((req[p]-current)*4*direction);
current=req[p];
}
p++;
direction=direction*(-1);
}
printf("%d",time);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  pat 1008