您的位置:首页 > 其它

The 2014 ACM-ICPC Asia Mudanjiang Regional Contest - I

2014-10-15 13:50 435 查看
Information Entropy

Time Limit: 2 Seconds Memory Limit: 131072 KB Special Judge

Information Theory is one of the most popular courses in Marjar University. In this course, there is an important chapter about information entropy.
Entropy is the average amount of information contained in each message received. Here, a message stands for an event, or a sample or a character drawn from a distribution or a data stream.
Entropy thus characterizes our uncertainty about our source of information. The source is also characterized by the probability distribution of the samples drawn from it. The idea here is that the less likely an event is, the more information it provides when
it occurs.
Generally, "entropy" stands for "disorder" or uncertainty. The entropy we talk about here was introduced by Claude E. Shannon in his 1948 paper "A Mathematical Theory of Communication".
We also call it Shannon entropy or information entropy to distinguish from other occurrences of the term, which appears in various parts of physics in different forms.
Named after Boltzmann's H-theorem, Shannon defined the entropy Η (Greek letter Η, η) of a discrete random variable X with possible values {x1, x2,
..., xn} and probability mass function P(X) as:

H(X)=E(−ln(P(x)))

Here E is the expected value operator. When taken from a finite sample, the entropy can explicitly be written as

H(X)=−∑i=1nP(xi)log b(P(xi))

Where b is the base of the logarithm used. Common values of b are 2, Euler's number e, and 10. The unit of entropy is bit for b = 2, nat for b = e,
and dit (or digit) for b = 10 respectively.
In the case of P(xi) = 0 for some i, the value of the corresponding summand 0 logb(0) is taken to be a well-known limit:

0log b(0)=limp→0+plog b(p)
Your task is to calculate the entropy of a finite sample with N values.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:
The first line contains an integer N (1 <= N <= 100) and a string S. The string S is one of "bit", "nat" or "dit", indicating the unit of entropy.
In the next line, there are N non-negative integers P1, P2, .., PN. Pi means the probability
of the i-th value in percentage and the sum of Pi will be 100.

Output

For each test case, output the entropy in the corresponding unit.
Any solution with a relative or absolute error of at most 10-8 will be accepted.

Sample Input

3
3 bit
25 25 50
7 nat
1 2 4 8 16 32 37
10 dit
10 10 10 10 10 10 10 10 10 10

Sample Output

1.500000000000
1.480810832465
1.000000000000

题意:直接套公式就行,只要注意p为0的时候,ans+=0。
#include <iostream>
#include <cstdio>
#include <climits>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <queue>
#include<stack>
#include <algorithm>
#include<ctime>
#define esp 1e-6
#define inf 0x0f0f0f0f
#define M 100
#define N 100
using namespace std;
int main()
{
int t;
int i,n;
char s[10];
double ans;
scanf("%d",&t);
while(t--)
{
ans=0;
int a;
double tt;
scanf("%d%s",&n,s);
if(strcmp(s,"bit")==0)
{
for(i=0;i<n;i++)
{
scanf("%d",&a);
tt=a*1.0/100.0;
if(tt==0)
ans+=0;
else
{
ans-=tt*log10(tt)/log10(2);
}
}
}

if(strcmp(s,"nat")==0)
{
for(i=0;i<n;i++)
{
scanf("%d",&a);
tt=a*1.0/100;
if(tt==0)
ans+=0;
else
{
ans-=tt*log(tt);
}
}
}

if(strcmp(s,"dit")==0)
{
for(i=0;i<n;i++)
{
scanf("%d",&a);
tt=a*1.0/100;
if(tt==0)
ans+=0;
else
{
ans-=tt*log10(tt);
}
}
}
printf("%.12f\n",ans);
}
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: