您的位置:首页 > 其它

hdu 2055 An easy problem (水题)

2014-09-22 12:17 113 查看


An easy problem

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 13944 Accepted Submission(s): 9410



Problem Description

we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, ... f(Z) = 26, f(z) = -26;

Give you a letter x and a number y , you should output the result of y+f(x).



Input

On the first line, contains a number T.then T lines follow, each line is a case.each case contains a letter and a number.



Output

for each case, you should the result of y+f(x) on a line.



Sample Input

6
R 1
P 2
G 3
r 1
p 2
g 3




Sample Output

19
18
10
-17
-14
-4


#include<iostream>
#include<cstdio>
#include<ctype.h>
using namespace std;

int main()
{
    int t;
    char x;
    int y;
    cin>>t;
    while(t--)
    {
        cin>>x>>y;
        if(isupper(x))
        {
            y=y+x-64;
        }
        else
        {
            y=y-(x-96);
        }
        cout<<y<<endl;
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: