您的位置:首页 > 其它

hdu 1016 Prime Ring Problem (DFS)

2014-10-09 22:31 260 查看


Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 27479 Accepted Submission(s): 12243



Problem Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.





Input

n (0 < n < 20).



Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.



Sample Input

6
8




Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2



我的第一个DFS

这个题目我想了很久

因为我对递归理解不深,所以顺便理解了一下递归的过程

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

int a[20];
int vis[20];

int prime(int n)
{
    int t=1;
    for(int i=2; i*i<=n; i++)
    {
        if(n%i==0)
        {
            t=0;
            break;
        }
    }
    return t;
}

void dfs(int i,int n)
{
    if(i==n)
    {
        if(prime(a
+1))
        {
            for(int j=1; j<=n; j++)
            {
                if(j==n)
                    printf("%d\n",a[j]);
                else
                    printf("%d ",a[j]);
            }
        }
        return;
    }
    for(int j=2; j<=n; j++)
    {
        if(prime(a[i]+j)&&vis[j]==0)
        {
            vis[j]=1;
            a[i+1]=j;
            dfs(i+1,n);
            vis[j]=0;
        }
    }
}

int main()
{
    int n;
    int t=0;
    while(scanf("%d",&n)==1)
    {
        memset(vis,0,sizeof(vis));
        printf("Case %d:\n",++t);
        a[1]=1;
        dfs(1,n);
        printf("\n");
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: