您的位置:首页 > 其它

hdu 1083 Courses(二分最大匹配)

2014-08-21 11:30 363 查看
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1083

[align=left]Problem Description[/align]
Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions:

. every student in the committee represents a different course (a student can represent a course if he/she visits that course)

. each course has a representative in the committee

Your program should read sets of data from a text file. The first line of the input file contains the number of the data sets. Each data set is presented in the following format:

P N

Count1 Student1 1 Student1 2 ... Student1 Count1

Count2 Student2 1 Student2 2 ... Student2 Count2

......

CountP StudentP 1 StudentP 2 ... StudentP CountP

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses . from course 1 to course P,
each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you'll find the Count i students, visiting the course,
each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.

There are no blank lines between consecutive sets of data. Input data are correct.

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

An example of program input and output:
 

[align=left]Sample Input[/align]

2
3 3
3 1 2 3
2 1 2
1 1
3 3
2 1 3
2 1 3
1 1

 

[align=left]Sample Output[/align]

YES
NO

 

[align=left]Source[/align]
Southeastern Europe 2000

题意是给你p门课程,n个学生,给每门课找课代表,每个人只能是一门课的课代表,如果每门课都能找到,输出YES,否则输出NO。

分析:求出学生和课程的最大匹配,如果匹配数等于课程数,则输出YES,否则NO。。

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<queue>
using namespace std;
const int maxn=310;
int mp[maxn][maxn];
int color[maxn];
int cx[maxn],cy[maxn];
int vis[maxn];
int nx,ny;
int p,n;
int find(int u)
{
for(int i=1;i<=ny;i++)
{
if(mp[u][i]&&!vis[i])
{
vis[i]=1;
if(cy[i]==-1||find(cy[i]))
{
cy[i]=u;
cx[u]=i;
return 1;
}
}
}
return 0;
}
int match()
{
int res=0;
memset(cx,-1,sizeof(cx));
memset(cy,-1,sizeof(cy));
for(int i=1;i<=nx;i++)
{
if(cx[i]==-1)
{
memset(vis,0,sizeof(vis));
res+=find(i);
}
}
return res;
}
int main()
{
//freopen("in.txt","r",stdin);
int t;
scanf("%d",&t);
while(t--)
{
memset(mp,0,sizeof(mp));
scanf("%d %d",&p,&n);
nx=p;
ny=n;
for(int i=1;i<=p;i++)
{
int c;
scanf("%d",&c);
while(c--)
{
int d;
scanf("%d",&d);
mp[i][d]=1;
}
}
int ans=match();
//printf("%d ",ans);
if(ans==p)
printf("YES\n");
else
printf("NO\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: