您的位置:首页 > 其它

hdu 4968 Improving the GPA(暴力枚举)

2014-08-19 20:08 323 查看
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4970



Problem Description

Xueba: Using the 4-Point Scale, my GPA is 4.0.

In fact, the ***ERAGE SCORE of Xueba is calculated by the following formula:

***ERAGE SCORE = ∑(Wi * SCOREi) / ∑(Wi) 1<=i<=N

where SCOREi represents the scores of the ith course and Wi represents the credit of the corresponding course.

To simplify the problem, we assume that the credit of each course is 1. In this way, the ***ERAGE SCORE is ∑(SCOREi) / N. In addition, SCOREi are all integers between 60 and 100, and we guarantee that ∑(SCOREi) can be divided by N.

In SYSU, the university usually uses the ***ERAGE SCORE as the standard to represent the students’ level. However, when the students want to study further in foreign countries, other universities will use the 4-Point Scale to represent the students’ level. There
are 2 ways of transforming each score to 4-Point Scale. Here is one of them.



The student’s average GPA in the 4-Point Scale is calculated as follows:
GPA = ∑(GPAi) / N

So given one student’s ***ERAGE SCORE and the number of the courses, there are many different possible values in the 4-Point Scale. Please calculate the minimum and maximum value of the GPA in the 4-Point Scale.



Input

The input begins with a line containing an integer T (1 < T < 500), which denotes the number of test cases. The next T lines each contain two integers ***GSCORE, N (60 <= ***GSCORE <= 100, 1 <= N <= 10).



Output

For each test case, you should display the minimum and maximum value of the GPA in the 4-Point Scale in one line, accurate up to 4 decimal places. There is a space between two values.



Sample Input

4
75 1
75 2
75 3
75 10




Sample Output

3.0000 3.0000
2.7500 3.0000
2.6667 3.1667
2.4000 3.2000

HintIn the third case, there are many possible ways to calculate the minimum value of the GPA in the 4-Point Scale.
For example, 
Scores 78 74 73 GPA = (3.0 + 2.5 + 2.5) / 3 = 2.6667
Scores 79 78 68 GPA = (3.0 + 3.0 + 2.0) / 3 = 2.6667
Scores 84 74 67 GPA = (3.5 + 2.5 + 2.0) / 3 = 2.6667
Scores 100 64 61 GPA = (4.0 + 2.0 + 2.0) / 3 = 2.6667




Source

2014 Multi-University Training Contest 9



思路:

因为此题的N很小Score也最多才100,所以可以直接暴力每种状态时的分数和,看所给的总分是否在其中,再在所有满足的分数范围中找最小与最大的。

代码如下:

#include <cstdio>
#define INF 1117
int main()
{
    int t;
    int avg, n;
    int i1, j1, k1, l1;
    int i2, j2, k2, l2;
    scanf("%d",&t);
    while(t--)
    {
        double minn = INF, maxx = -INF;
        scanf("%d%d",&avg,&n);
        int sum = avg*n;
        for(int i = 0; i <= n; i++)
        {
            i1 = i*100;
            i2 = i*85;
            for(int j = 0; j <= n-i; j++)
            {
                j1 = j*84;
                j2 = j*80;
                for(int k=0; k <= n-i-j; k++)
                {
                    k1 = k*79;
                    k2 = k*75;
                    for(int l = 0; l <= n-i-j-k; l++)
                    {
                        l1 = l*74;
                        l2 = l*70;
                        int tmp = n-i-j-k-l;
                        int maxsum = i1+j1+k1+l1+tmp*69;
                        int minsum = i2+j2+k2+l2+tmp*60;
                        if(sum>=minsum && sum<=maxsum)
                        {
                            double tt = i*4 + j*3.5 + k*3.0 + l*2.5 + tmp*2;
                            if(tt < minn)
                            {
                                minn = tt;
                            }
                            if(tt > maxx)
                            {
                                maxx = tt;
                            }

                        }
                    }
                }
            }
        }
        printf("%.4lf %.4lf\n",minn/(n*1.0),maxx/(n*1.0));
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: