您的位置:首页 > 其它

hdu 4970 Killing Monsters(数学题)

2014-08-19 21:03 309 查看
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4970



Problem Description

Kingdom Rush is a popular TD game, in which you should build some towers to protect your kingdom from monsters. And now another wave of monsters is coming and you need again to know whether you can get through it.

The path of monsters is a straight line, and there are N blocks on it (numbered from 1 to N continuously). Before enemies come, you have M towers built. Each tower has an attack range [L, R], meaning that it can attack all enemies in every block i, where L<=i<=R.
Once a monster steps into block i, every tower whose attack range include block i will attack the monster once and only once. For example, a tower with attack range [1, 3] will attack a monster three times if the monster is alive, one in block 1, another in
block 2 and the last in block 3.

A witch helps your enemies and makes every monster has its own place of appearance (the ith monster appears at block Xi). All monsters go straightly to block N.

Now that you know each monster has HP Hi and each tower has a value of attack Di, one attack will cause Di damage (decrease HP by Di). If the HP of a monster is decreased to 0 or below 0, it will die and disappear.

Your task is to calculate the number of monsters surviving from your towers so as to make a plan B.



Input

The input contains multiple test cases.

The first line of each case is an integer N (0 < N <= 100000), the number of blocks in the path. The second line is an integer M (0 < M <= 100000), the number of towers you have. The next M lines each contain three numbers, Li, Ri, Di (1 <= Li <= Ri <= N, 0
< Di <= 1000), indicating the attack range [L, R] and the value of attack D of the ith tower. The next line is an integer K (0 < K <= 100000), the number of coming monsters. The following K lines each contain two integers Hi and Xi (0 < Hi <= 10^18, 1 <= Xi
<= N) indicating the ith monster’s live point and the number of the block where the ith monster appears.

The input is terminated by N = 0.



Output

Output one line containing the number of surviving monsters.



Sample Input

5
2
1 3 1
5 5 2
5
1 3
3 1
5 2
7 3
9 1
0




Sample Output

3

HintIn the sample, three monsters with origin HP 5, 7 and 9 will survive.




Source

2014 Multi-University Training Contest
9



官方题解:http://blog.sina.com.cn/s/blog_6bddecdc0102uzwm.html

代码如下:

//#pragma warning (disable:4786)
#include <cstdio>
#include <cmath>
#include <cstring>
#include <string>
#include <cstdlib>
#include <climits>
#include <ctype.h>
#include <queue>
#include <stack>
#include <vector>
#include <utility>
#include <deque>
#include <set>
#include <map>
#include <iostream>
#include <algorithm>
using namespace std;
const double eps = 1e-9;
//const double pi = atan(1.0)*4;
const double pi = 3.1415926535897932384626;
#define INF 1e18
//typedef long long LL;
typedef __int64 LL;
const int MAXN = 200017;
int num[MAXN];
LL sum[MAXN];
int main()
{
    int l,r,d;
    int tow,n,m,x;
    LL h;
    while(scanf("%d",&n) && n)
    {
        scanf("%d",&tow);
        memset(num,0,sizeof(num));
        memset(sum,0,sizeof(sum));
        for(int i = 0; i < tow; i++)
        {
            scanf("%d%d%d",&l,&r,&d);
            num[l] += d;
            num[r+1] -= d;
        }

        for(int i = 1; i <= n; i++)
        {
            sum[i] = sum[i-1]+num[i];
        }

        for(int i = n; i >= 1; i--)
        {
            sum[i] = sum[i+1]+sum[i];
        }
        int cont = 0;
        scanf("%d",&m);
        for(int i = 0; i < m; i++)
        {
            scanf("%I64d%d",&h,&x);
            if(sum[x] < h)
            {
                cont++;
            }
        }
        printf("%d\n",cont);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: