您的位置:首页 > 移动开发 > IOS开发

uva 11111 - Generalized Matrioshkas

2014-08-10 16:23 274 查看

Problem B - Generalized Matrioshkas
Vladimir worked for years making matrioshkas, those nesting dolls that certainly represent truly Russian craft. A matrioshka is a doll that may be opened in two halves, so that one finds another doll inside. Then this doll may be opened to find another one inside it. This can be repeated several times, till a final doll -that cannot be opened- is reached.

Recently, Vladimir realized that the idea of nesting dolls might be generalized to nesting toys. Indeed, he has designed toys that contain toys but in a more general sense. One of these toys may be opened in two halves and it may have more than one toy inside it. That is the new feature that Vladimir wants to introduce in his new line of toys.

Vladimir has developed a notation to describe how nesting toys should be constructed. A toy is represented with a positive integer, according to its size. More precisely: if when opening the toy represented by m we find the toys represented by n1, n2, ..., nr, it must be true that n1 + n2 + ... + nr < m. And if this is the case, we say that toy m contains directly the toys n1, n2, ..., nr . It should be clear that toys that may be contained in any of the toys n1, n2, ..., nr are not considered as directly contained in the toy m.

A generalized matrioshka is denoted with a non-empty sequence of non zero integers of the form:

[align=CENTER]a1 a2 ... aN[/align]
such that toy k is represented in the sequence with two integers - k and k, with the negative one occurring in the sequence first that the positive one.

For example, the sequence

[align=CENTER]-9 -7 -2 2 -3 -2 -1 1 2 3 7 9[/align]
represents a generalized matrioshka conformed by six toys, namely, 1, 2 (twice), 3, 7 and 9. Note that toy 7 contains directly toys 2 and 3. Note that the first copy of toy 2 occurs left from the second one and that the second copy contains directly a toy 1. It would be wrong to understand that the first -2 and the last 2 should be paired.

On the other hand, the following sequences do not describe generalized matrioshkas:

[align=CENTER]-9 -7 -2 2 -3 -1 -2 2 1 3 7 9[/align]
because toy 2 is bigger than toy 1 and cannot be allocated inside it.

[align=CENTER]-9 -7 -2 2 -3 -2 -1 1 2 3 7 -2 2 9[/align]
because 7 and 2 may not be allocated together inside 9.

[align=CENTER]-9 -7 -2 2 -3 -1 -2 3 2 1 7 9[/align]
because there is a nesting problem within toy 3.

Your problem is to write a program to help Vladimir telling good designs from bad ones.

Input

The input file contains several test cases, each one of them in a separate line. Each test case is a sequence of non zero integers, each one with an absolute value less than 107.

Output

Output texts for each input case are presented in the same order that input is read.

For each test case the answer must be a line of the form

:-) Matrioshka!

if the design describes a generalized matrioshka. In other case, the answer should be of the form

:-( Try again.


Sample Input

-9 -7 -2 2 -3 -2 -1 1 2 3 7 9
-9 -7 -2 2 -3 -1 -2 2 1 3 7 9
-9 -7 -2 2 -3 -1 -2 3 2 1 7 9
-100 -50 -6 6 50 100
-100 -50 -6 6 45 100
-10 -5 -2 2 5 -4 -3 3 4 10
-9 -5 -2 2 5 -4 -3 3 4 9


Sample Output

:-) Matrioshka!
:-( Try again.
:-( Try again.
:-) Matrioshka!
:-( Try again.
:-) Matrioshka!
:-( Try again.


#include <iostream>
#include <stack>
#include <cstring>
#include <cstdio>
#include <string>
#include <algorithm>
#include <queue>
#include <set>
#include <map>
#include <fstream>
#include <stack>
#include <list>
#include <sstream>
using namespace std;
/*
题意:一个可以嵌套娃娃的娃娃,然后嵌套在里面的娃娃又可以继续嵌套娃娃。
然后要求直接嵌套在里面(内一层)的娃娃的尺寸大小之和不能超过外面的。
(要特别注意输入)
*/
#define ms(arr, val) memset(arr, val, sizeof(arr))
#define N 50000
#define INF 0x3fffffff
#define vint vector<int>
#define sint set<int>
#define mint map<int, int>
#define lint list<int>
#define sch stack<char>
int seq
, sum
, top, a;
string line;
void init()
{
ms(sum, 0);
top = -1;
}

bool judge()
{
init();
istringstream iss(line);
while (iss>>a)
{
if (a < 0)
{
sum[++top] -= a;//记录当前层的和
seq[top] = a;
}
else
{
if (top < 0)//序列为空
{
return false;
}
if (-seq[top] != a)//不等
{
return false;
}
if (-seq[top] <= sum[top + 1])//当前数字不大于内层和
{
return false;
}
//满足条件,可匹配
sum[top + 1] = 0;//内层和清空,不影响后面操作
top--;
}
}
return top < 0 ? true : false;
}
int main()
{
while (getline(cin, line))
{
cout << (judge() ? ":-) Matrioshka!" : ":-( Try again.") << endl;
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: