您的位置:首页 > 移动开发 > IOS开发

UVa 11111 Generalized Matrioshkas

2013-11-14 16:30 411 查看
d

Vladimir worked for years making matrioshkas, those nesting dolls that certainly represent truly Russian craft. A matrioshka is a doll that may be opened in two halves, so that one finds another doll
inside. Then this doll may be opened to find another one inside it. This can be repeated several times, till a final doll -that cannot be opened- is reached.
Recently, Vladimir realized that the idea of nesting dolls might be generalized to nesting toys. Indeed, he has designed toys that contain toys but in a more general sense. One of these toys may be opened in
two halves and it may have more than one toy inside it. That is the new feature that Vladimir wants to introduce in his new line of toys.
Vladimir has developed a notation to describe how nesting toys should be constructed. A toy is represented with a positive integer, according to its size. More precisely: if when opening the toy represented
by m we find the toys represented by n1, n2, ..., nr, it
must be true that n1 + n2 + ... + nr < m. And if this is the case, we say that toy m contains directly the
toys n1, n2, ..., nr . It should be clear that toys that may be contained in any of the toys n1, n2, ..., nr are
not considered as directly contained in the toy m.
A generalized matrioshka is denoted with a non-empty sequence of non zero integers of the form:

[align=CENTER]a1 a2 ... aN[/align]

such that toy k is represented in the sequence with two integers - k and k, with the negative one occurring in the sequence first that the positive one.
For example, the sequence

[align=CENTER]-9 -7 -2 2 -3 -2 -1 1 2 3 7 9[/align]

represents a generalized matrioshka conformed by six toys, namely, 1, 2 (twice), 3, 7 and 9. Note that toy 7 contains
directly toys 2 and 3. Note that the first copy of toy 2 occurs left from the second one and that the second copy contains directly a toy 1. It would be
wrong to understand that the first -2 and the last 2 should be paired.
On the other hand, the following sequences do not describe generalized matrioshkas:

[align=CENTER]-9 -7 -2 2 -3 -1 -2 2 1 3 7 9[/align]

because toy 2 is bigger than toy 1 and cannot be allocated inside it.

[align=CENTER]-9 -7 -2 2 -3 -2 -1 1 2 3 7 -2 2 9[/align]

because 7 and 2 may not be allocated together inside 9.

[align=CENTER]-9 -7 -2 2 -3 -1 -2 3 2 1 7 9[/align]

because there is a nesting problem within toy 3.

Your problem is to write a program to help Vladimir telling good designs from bad ones.

Input

The input file contains several test cases, each one of them in a separate line. Each test case is a sequence of non zero integers, each one with an absolute value less than 107.

Output

Output texts for each input case are presented in the same order that input is read.
For each test case the answer must be a line of the form

:-) Matrioshka!

if the design describes a generalized matrioshka. In other case, the answer should be of the form

:-( Try again.

Sample Input

-9 -7 -2 2 -3 -2 -1 1 2 3 7 9
-9 -7 -2 2 -3 -1 -2 2 1 3 7 9
-9 -7 -2 2 -3 -1 -2 3 2 1 7 9
-100 -50 -6 6 50 100
-100 -50 -6 6 45 100
-10 -5 -2 2 5 -4 -3 3 4 10
-9 -5 -2 2 5 -4 -3 3 4 9


Sample Output

:-) Matrioshka!
:-( Try again.
:-( Try again.
:-) Matrioshka!
:-( Try again.
:-) Matrioshka!
:-( Try again.


这个题号称是括号匹配的加强版,不仅要匹配,还要判断内部包含之和是否小于外层的数;

如最后一个测试案例,尽管匹配但是因为9里面包含5和4,而9并不大于5与4的和,就导致输出try again。

题目还有一个地方比较恶心,就是输入,分析知遇到换行符则该行输入结束,因此要用getchar()!='\n'来判断输入结束的情况。

还要注意的是数组的大小,题目没有明显提示,我实在poj上的discuss中找到的。

最好要考虑的一个因素就是输入数目总个数为奇数,此时可直接输出try again。

代码如下:

#include <stdio.h>
int main(void)
{
int a[30000],stack[1000];
int i,len,j;
while(scanf("%d",&a[0])!=EOF)
{
i=1;
while(getchar()!='\n')
scanf("%d",&a[i++]);
len=i;
if(i%2)
{
printf(":-( Try again.\n");
continue;
}
int count[1000]={0};
//怎样判断每个数内部是否超出范围???
stack[0]=a[0];
for(i=1,j=0;i<len&&j>=0;i++)
{
if(a[i]<0)
stack[++j]=a[i];
else
{
if(!(stack[j]+a[i])&&stack[j]+count[j]<0)
{
count[j]=0;
j--;
count[j]+=a[i];
}
else
{
printf(":-( Try again.\n");
break;
}
}
}
if(j==-1)
printf(":-) Matrioshka!\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: