您的位置:首页 > 移动开发 > IOS开发

UVa 11111 Generalized Matrioshkas (栈)

2013-10-22 20:48 369 查看

11111 - Generalized Matrioshkas

Time limit: 3.000 seconds

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=103&page=show_problem&problem=2052

Vladimir worked for years making matrioshkas, those nesting dolls that certainly represent truly Russian craft. A matrioshka is a doll that may be opened in two halves, so that one finds another doll inside. Then this doll may be opened to find
another one inside it. This can be repeated several times, till a final doll -that cannot be opened- is reached.

Recently, Vladimir realized that the idea of nesting dolls might be generalized to nesting toys. Indeed, he has designed toys that contain toys but in a more general sense. One of these toys may be opened in two halves and it may have more than one toy inside
it. That is the new feature that Vladimir wants to introduce in his new line of toys.

Vladimir has developed a notation to describe how nesting toys should be constructed. A toy is represented with a positive integer, according to its size. More precisely: if when opening the toy represented bym we find
the toys represented by n1,
n2, ...,
nr, it must be true thatn1 +n2 + ... +
nr <m. And if this is the case, we say that toymcontains directly the toysn1,n2,...,
nr . It should be clear that toys that may be contained in any of the toysn1,n2,...,
nr are not considered as directly contained in the toym.

A generalized matrioshka is denoted with a non-empty sequence of non zero integers of the form:

a1 a2 ... aN
such that toy k is represented in the sequence with two integers-k and
k, with the negative one occurring in the sequence first that the positive one.
For example, the sequence

-9 -7 -2 2 -3 -2 -1 1 2 3 7 9
represents a generalized matrioshka conformed by six toys, namely,
1, 2 (twice), 3,
7 and 9. Note that toy 7 contains directly toys2 and3. Note that the first copy of toy2 occurs left from the second one
and that the second copy contains directly a toy1. It would be wrong to understand that the first-2 and the last
2 should be paired.
On the other hand, the following sequences do not describe generalized matrioshkas:

-9 -7 -2 2 -3 -1 -2 2 1 3 7 9
because toy 2 is bigger than toy 1 and cannot be allocated inside it.

-9 -7 -2 2 -3 -2 -1 1 2 3 7 -2 2 9
because 7 and 2 may not be allocated together inside9.

-9 -7 -2 2 -3 -1 -2 3 2 1 7 9
because there is a nesting problem within toy 3.

Your problem is to write a program to help Vladimir telling good designs from bad ones.

Input

The input file contains several test cases, each one of them in a separate line. Each test case is a sequence of non zero integers, each one with an absolute value less than107.

Output

Output texts for each input case are presented in the same order that input is read.

For each test case the answer must be a line of the form

:-) Matrioshka!

if the design describes a generalized matrioshka. In other case, the answer should be of the form

:-( Try again.

Sample Input

-9 -7 -2 2 -3 -2 -1 1 2 3 7 9
-9 -7 -2 2 -3 -1 -2 2 1 3 7 9
-9 -7 -2 2 -3 -1 -2 3 2 1 7 9
-100 -50 -6 6 50 100
-100 -50 -6 6 45 100
-10 -5 -2 2 5 -4 -3 3 4 10
-9 -5 -2 2 5 -4 -3 3 4 9


Sample Output

:-) Matrioshka!
:-( Try again.
:-( Try again.
:-) Matrioshka!
:-( Try again.
:-) Matrioshka!
:-( Try again.


一图流:



模拟栈即可。

完整代码:

/*0.069s*/

#include <cstdio>
const int maxn = 10000;

struct Toy
{
	int n, s;
} s[maxn];
int t[maxn];

bool solve(int n)
{
	int i, top;
	for (i = 0, top = -1; i < n; i++)
	{
		if (t[i] < 0)
		{
			s[++top].s = -t[i];
			s[top].n = 0;
		}
		else
		{
			if ((t[i] != s[top].s))
				return false;
			if (top)
				s[--top].n += t[i];
			if (s[top].s <= s[top].n)
				return false;
		}
	}
	return true;
}

int main()
{
	int n;
	char c;
	for (n = 0; ~scanf("%d%c", &t[n++], &c);)
	{
		if (c == '\n')
		{
			if (n % 2 == 1)
				puts(":-( Try again.");
			else
				puts(solve(n) ? ":-) Matrioshka!" : ":-( Try again.");
			n = 0;
		}
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: